aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-08-29 16:02:50 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-09-01 11:14:16 +0530
commita0596a2f27c339bcb4c5d3f2ffc8d6df38ff7947 (patch)
tree4c7464a39a093903a88d5a6520011ca068028e4b
parentf618086220106a15842fce9b4cbe1525a1473f42 (diff)
downloadguix-a0596a2f27c339bcb4c5d3f2ffc8d6df38ff7947.tar
guix-a0596a2f27c339bcb4c5d3f2ffc8d6df38ff7947.tar.gz
gnu: python2-larch: Enable tests.
* gnu/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python2-larch)[source]: Use it. [arguments]: Move 'check' phase to before 'build' phase.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch29
-rw-r--r--gnu/packages/python.scm17
3 files changed, 46 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index fbc6ff057f..2e40026e53 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -962,6 +962,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-genshi-fix-tests-on-python-3.5.patch \
%D%/packages/patches/python-genshi-isstring-helper.patch \
%D%/packages/patches/python-genshi-stripping-of-unsafe-script-tags.patch \
+ %D%/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch \
%D%/packages/patches/python-parse-too-many-fields.patch \
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
%D%/packages/patches/python-statsmodels-fix-tests.patch \
diff --git a/gnu/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch b/gnu/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch
new file mode 100644
index 0000000000..f1db5d7c3b
--- /dev/null
+++ b/gnu/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch
@@ -0,0 +1,29 @@
+From ca548da9ba78ddee90779051210e3e89185e4f7d Mon Sep 17 00:00:00 2001
+From: Michel Alexandre Salim <michel@michel-slm.name>
+Date: Mon, 15 Feb 2016 23:03:42 +0700
+Subject: coverage-4.0a6 compatibility
+
+coverage 4.0a6 no longer generates .coverage file, so use -f when
+deleting .coverage to ensure deletion does not fail.
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+(limited to 'Makefile')
+
+diff --git a/Makefile b/Makefile
+index 7818f57..362c07f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,7 +23,7 @@ fsck-larch.1: fsck-larch.1.in fsck-larch
+
+ check:
+ python -m CoverageTestRunner --ignore-missing-from=without-tests
+- rm .coverage
++ rm -f .coverage
+ ./insert-remove-test tempdir 100
+ rm -r tempdir larch.log
+ cmdtest tests
+--
+cgit v1.1
+
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8bdd865af3..874ad82d91 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -68,6 +68,7 @@
#:use-module (gnu packages attr)
#:use-module (gnu packages backup)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
@@ -14193,12 +14194,26 @@ happens using the @code{logging} library.")
(uri (string-append
"http://git.liw.fi/cgi-bin/cgit/cgit.cgi/larch/snapshot/larch-"
version ".tar.gz"))
+ (patches (search-patches
+ "python2-larch-coverage-4.0a6-compatibility.patch"))
(sha256
(base32
"1p4knkkavlqymgciz2wbcnfrdgdbafhg14maplnk4vbw0q8xs663"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2))
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ ;; check phase needs to be run before the build phase. If not,
+ ;; coverage-test-runner looks for tests for the built source files,
+ ;; and fails.
+ (delete 'check)
+ (add-before 'build 'check
+ (lambda _
+ (zero? (system* "make" "check")))))))
+ (native-inputs
+ `(("cmdtest" ,cmdtest)
+ ("python2-coverage-test-runner" ,python2-coverage-test-runner)))
(propagated-inputs
`(("python2-tracing" ,python2-tracing)))
(home-page "https://liw.fi/larch/")