aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-08-16 10:27:04 +0000
committerEfraim Flashner <efraim@flashner.co.il>2017-09-03 16:18:04 +0300
commit833b7e0af05b88254928a8ea15d05d5d22dc2df9 (patch)
tree1cf9fff730d2ad172c523b5671272b798ab01475
parent3c7c916161581a0cd6b207717b0a93e20de1fe43 (diff)
downloadguix-833b7e0af05b88254928a8ea15d05d5d22dc2df9.tar
guix-833b7e0af05b88254928a8ea15d05d5d22dc2df9.tar.gz
gnu: mate: Use https.
* gnu/packages/mate.scm (mate-icon-theme)[source, home-page]: Use https. (mate-themes)[source, home-page]: Likewise. (mate-desktop)[source, home-page]: Likewise. (libmateweather)[source, home-page]: Likewise. (mate-menus)[source, home-page]: Likewise. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/mate.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 316385a6f8..66c40c6926 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 ng0 <ng0@infotropique.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,7 +41,7 @@
(version "1.18.2")
(source (origin
(method url-fetch)
- (uri (string-append "http://pub.mate-desktop.org/releases/"
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
@@ -52,7 +53,7 @@
("intltool" ,intltool)
("gtk+" ,gtk+)
("icon-naming-utils" ,icon-naming-utils)))
- (home-page "http://mate-desktop.org/")
+ (home-page "https://mate-desktop.org/")
(synopsis "The MATE desktop environment icon theme")
(description
"This package contains the default icon theme used by the MATE desktop.")
@@ -64,7 +65,7 @@
(version "3.22.11")
(source (origin
(method url-fetch)
- (uri (string-append "http://pub.mate-desktop.org/releases/themes/"
+ (uri (string-append "https://pub.mate-desktop.org/releases/themes/"
(version-major+minor version) "/mate-themes-"
version ".tar.xz"))
(sha256
@@ -79,7 +80,7 @@
("gdk-pixbuf" ,gdk-pixbuf)
("gtk-engines" ,gtk-engines)
("murrine" ,murrine)))
- (home-page "http://mate-desktop.org/")
+ (home-page "https://mate-desktop.org/")
(synopsis
"Official themes for the MATE desktop")
(description
@@ -95,7 +96,7 @@ themes for both gtk+-2 and gtk+-3.")
(version "1.18.0")
(source (origin
(method url-fetch)
- (uri (string-append "http://pub.mate-desktop.org/releases/"
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
@@ -115,7 +116,7 @@ themes for both gtk+-2 and gtk+-3.")
("startup-notification" ,startup-notification)))
(propagated-inputs
`(("dconf" ,dconf))) ; mate-desktop-2.0.pc
- (home-page "http://mate-desktop.org/")
+ (home-page "https://mate-desktop.org/")
(synopsis "Library with common API for various MATE modules")
(description
"This package contains a public API shared by several applications on the
@@ -128,7 +129,7 @@ desktop and the mate-about program.")
(version "1.18.1")
(source (origin
(method url-fetch)
- (uri (string-append "http://pub.mate-desktop.org/releases/"
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
@@ -163,7 +164,7 @@ desktop and the mate-about program.")
;; both of these are requires.private in mateweather.pc
`(("libsoup" ,libsoup)
("libxml2" ,libxml2)))
- (home-page "http://mate-desktop.org/")
+ (home-page "https://mate-desktop.org/")
(synopsis "MATE library for weather information from the Internet")
(description
"This library provides access to weather information from the internet for
@@ -176,7 +177,7 @@ the MATE desktop environment.")
(version "1.18.0")
(source (origin
(method url-fetch)
- (uri (string-append "http://pub.mate-desktop.org/releases/"
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
@@ -203,7 +204,7 @@ the MATE desktop environment.")
(inputs
`(("glib" ,glib)
("python" ,python-2)))
- (home-page "http://mate-desktop.org/")
+ (home-page "https://mate-desktop.org/")
(synopsis "Freedesktop menu specification implementation for MATE")
(description
"The package contains an implementation of the freedesktop menu