aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEthan R. Jones <doubleplusgood23@gmail.com>2017-05-14 13:01:53 -0400
committerLudovic Courtès <ludo@gnu.org>2017-09-02 00:58:11 +0200
commit7bd65a6304b6639554b625db32a1e887deab9158 (patch)
tree08155380010651f5966a64cb1bd0e9ae326ce375
parent75f23951ad1d42f9d236cd11390dab35351083da (diff)
downloadguix-7bd65a6304b6639554b625db32a1e887deab9158.tar
guix-7bd65a6304b6639554b625db32a1e887deab9158.tar.gz
gnu: swish-e: Work around compilation error and test failures.
* gnu/packages/search.scm (swish-e)[inputs]: Remove ZLIB and LIBXML2. [arguments]: Add #:configure-flags. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/search.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index cc8c0630bb..62da3be0fd 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -264,15 +264,17 @@ conflict with slocate compatibility.")
;; building: xpdf, catdoc, MP3::Tag, Spreadsheet::ParseExcel,
;; HTML::Entities.
(inputs
- `(("libxml" ,libxml2)
- ("zlib" ,zlib)
- ("perl" ,perl)
+ `(("perl" ,perl)
("perl-uri" ,perl-uri)
("perl-html-parser" ,perl-html-parser)
("perl-html-tagset" ,perl-html-tagset)
("perl-mime-types" ,perl-mime-types)))
(arguments
- `(#:phases (modify-phases %standard-phases
+ `(;; XXX: This fails to build with zlib (API mismatch) and tests fail
+ ;; with libxml2, so disable both.
+ #:configure-flags (list (string-append "--without-zlib")
+ (string-append "--without-libxml2"))
+ #:phases (modify-phases %standard-phases
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))