aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-08-13 22:11:48 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-09-02 13:11:31 +0200
commit7ae9542bf317c6ee4359cd8665fdc9c836f091ef (patch)
treeb0c010bfd72a0c3e75a38426d2a7e93955e3670a
parent7ade80220b68ce0f7a2eac7627b6a5059f3e2c33 (diff)
downloadguix-7ae9542bf317c6ee4359cd8665fdc9c836f091ef.tar
guix-7ae9542bf317c6ee4359cd8665fdc9c836f091ef.tar.gz
gnu: Add prison.
* gnu/packages/kde-frameworks.scm (prison): New variable.
-rw-r--r--gnu/packages/kde-frameworks.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 292b537a12..58bc742365 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages acl)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages aidc)
#:use-module (gnu packages attr)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
@@ -1209,6 +1210,31 @@ querying and interacting with hardware independently of the underlying operating
system.")
(license license:lgpl2.1+)))
+(define-public prison
+ (package
+ (name "prison")
+ (version "5.34.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32 "00wj4yyfhhcq9b54civ5hy1grz70mmi676x50y12crcbbgkxm1lx"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("libdmtx", libdmtx)
+ ("qrencode" ,qrencode)
+ ("qtbase" ,qtbase))) ;; TODO: rethink: nix propagates this
+ (home-page "https://api.kde.org/frameworks/prison/html/index.html")
+ (synopsis "Barcode generation abstraction layer")
+ (description "Prison is a Qt-based barcode abstraction layer/library and
+provides uniform access to generation of barcodes with data.")
+ (license license:lgpl2.1+)))
+
(define-public sonnet
(package
(name "sonnet")