aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-08-13 22:07:50 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-09-02 13:11:30 +0200
commit7ade80220b68ce0f7a2eac7627b6a5059f3e2c33 (patch)
tree82a89ee2f4aacdaa25a98d779c0e8897fc0dab35
parent3fe666aa29e72a9fbb1e267eebcd7d197ec802f3 (diff)
downloadguix-7ade80220b68ce0f7a2eac7627b6a5059f3e2c33.tar
guix-7ade80220b68ce0f7a2eac7627b6a5059f3e2c33.tar.gz
gnu: Add libdmtx.
* gnu/packages/aidc.scm (libdmtx): New variable.
-rw-r--r--gnu/packages/aidc.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index 0864aa6490..fa4555ede6 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darringon <jmd@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,3 +70,26 @@ a mobile phone with CCD. The capacity of QR Code is up to 7000 digits or 4000
characters, and is highly robust.")
(license license:lgpl2.1+)
(home-page "https://fukuchi.org/works/qrencode")))
+
+(define-public libdmtx
+ (package
+ (name "libdmtx")
+ (version "0.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/libdmtx/" name "/" version "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32 "0xnxx075ycy58n92yfda2z9zgd41h3d4ik5d9l197lzsqim5hb5n"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://libdmtx.sourceforge.net/")
+ (synopsis "Library for reading and writing Data Matrix 2D barcodes")
+ (description "libdmtx is open source software for reading and writing Data
+Matrix 2D barcodes on Linux and Unix. At its core libdmtx is a shared
+library, allowing C/C++ programs to use its capabilities without restrictions
+or overhead.")
+ (license license:bsd-3)))