aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-08-26 22:54:55 -0400
committerLeo Famulari <leo@famulari.name>2017-09-02 11:07:56 -0400
commit631c9f743fe45dfb1cc5d174b03e737a264b18e6 (patch)
treece296b5f6b5f922789ee66385e2538c5e5238dd7
parentd536113df0049e979a088a7794016d77a784b95c (diff)
downloadguix-631c9f743fe45dfb1cc5d174b03e737a264b18e6.tar
guix-631c9f743fe45dfb1cc5d174b03e737a264b18e6.tar.gz
gnu: net-tools: Build from a source archive instead of a Git checkout.
* gnu/packages/linux.scm (net-tools)[source]: Use url-fetch and adjust the source URL accordingly. [native-inputs]: Add UNZIP. (net-tools-for-tests)[native-inputs]: Add field so that we can exclude UNZIP.
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 17 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c01cbf1b3d..60bb967cb4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1212,14 +1212,14 @@ messages and are accompanied by a set of manpages.")
(name "net-tools")
(version (string-append "1.60-" revision "." (string-take commit 7)))
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.code.sf.net/p/net-tools/code")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
+ (method url-fetch)
+ (uri (string-append "https://sourceforge.net/code-snapshots/git/"
+ "n/ne/net-tools/code.git/net-tools-code-"
+ commit ".zip"))
+ (file-name (string-append name "-" version ".zip"))
(sha256
(base32
- "189mdjfbd7j7j0jysy34nqn5byy9g5f6ylip1sikk7kz08vjml4s"))))
+ "0hz9fda9d78spp774b6rr5xaxav7cm4h0qcpxf70rvdbrf6qx7vy"))))
(home-page "http://net-tools.sourceforge.net/")
(build-system gnu-build-system)
(arguments
@@ -1266,7 +1266,8 @@ messages and are accompanied by a set of manpages.")
(string-append "BASEDIR=" out)
(string-append "INSTALLNLSDIR=" out "/share/locale")
(string-append "mandir=/share/man")))))
- (native-inputs `(("gettext" ,gettext-minimal)))
+ (native-inputs `(("gettext" ,gettext-minimal)
+ ("unzip" ,unzip)))
(synopsis "Tools for controlling the network subsystem in Linux")
(description
"This package includes the important tools for controlling the network
@@ -1355,6 +1356,15 @@ configuration (iptunnel, ipmaddr).")
(string-append "INSTALLNLSDIR=" out "/share/locale")
(string-append "mandir=/share/man")))))
+ ;; We added unzip to the net-tools package's native-inputs when
+ ;; switching its source from a Git checkout to a zip archive. We
+ ;; need to specify the native-inputs here to keep unzip out of the
+ ;; build of net-tools-for-tests, so that we don't have to rebuild
+ ;; many packages on the master branch. We can make
+ ;; net-tools-for-tests inherit directly from net-tools in the next
+ ;; core-updates cycle.
+ (native-inputs `(("gettext" ,gettext-minimal)))
+
;; Use the big Debian patch set (the thing does not even compile out of
;; the box.)
;; XXX The patch is not actually applied, due to a bug in the 'patch' phase