aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-09-02 12:06:55 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-04 07:56:11 +0100
commit59e03ba0a466d8b48a3ddd33d384e53c66fb4b10 (patch)
tree790cb43fc19d67db9c1b46e7546a444ad2574383
parentd10092b849153dc27cfed0a9601fde6c7bdec918 (diff)
downloadguix-59e03ba0a466d8b48a3ddd33d384e53c66fb4b10.tar
guix-59e03ba0a466d8b48a3ddd33d384e53c66fb4b10.tar.gz
gnu: Add emacs-go-mode.
* gnu/packages/emacs.scm (emacs-go-mode): New variable.
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b3d5fc97e2..7423306290 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1193,6 +1193,26 @@ Using emacs-direnv means that programs started from Emacs will use the
environment set through Direnv.")
(license license:gpl3+)))
+(define-public emacs-go-mode
+ (package
+ (name "emacs-go-mode")
+ (version "1.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dominikh/go-mode.el/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1adngbjyb8qnwg7n6r2y31djw9j6qf3b9fi63zd85035q7x4ljnm"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/dominikh/go-mode.el")
+ (synopsis "Go mode for Emacs")
+ (description
+ "This package provides go-mode, an Emacs mode for working with software
+written in the Go programming language.")
+ (license license:bsd-3)))
+
(define-public emacs-google-maps
(package
(name "emacs-google-maps")