aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-03 15:27:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-03 18:01:12 +0300
commit5804c7b616a39c05280aaabf3cec753db5fc6002 (patch)
treee65c96cc58a0c64be3ebc933987bede8ef8667c4
parent6a548c56ef422f18a1effe89d82671f2ffae6a90 (diff)
downloadguix-5804c7b616a39c05280aaabf3cec753db5fc6002.tar
guix-5804c7b616a39c05280aaabf3cec753db5fc6002.tar.gz
gnu: libmateweather: Update inputs.
* gnu/packages/mate.scm (libmateweather)[inputs]: Remove gdk-pixpuf. Move dconf ... [native-inputs]: ... to here.
-rw-r--r--gnu/packages/mate.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 8e3958879f..c64e26124d 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -133,14 +133,13 @@ desktop and the mate-about program.")
"0z6vfh42fv9rqjrraqfpf6h9nd9h662bxy3l3r48j19xvxrwmx3a"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
+ '(#:configure-flags
(list (string-append "--with-zoneinfo-dir="
(assoc-ref %build-inputs "tzdata")
"/share/zoneinfo"))
#:phases
(modify-phases %standard-phases
- (add-before
- 'check 'pre-check
+ (add-before 'check 'fix-tzdata-location
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "data/check-timezones.sh"
(("/usr/share/zoneinfo/zone.tab")
@@ -150,11 +149,10 @@ desktop and the mate-about program.")
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)
+ ("dconf" ,dconf)
("glib:bin" ,glib "bin")))
(inputs
- `(("dconf" ,dconf)
- ("gdk-pixbuf" ,gdk-pixbuf)
- ("gtk+" ,gtk+)
+ `(("gtk+" ,gtk+)
("tzdata" ,tzdata)))
(propagated-inputs
;; both of these are requires.private in mateweather.pc