aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Wilson <david@daviwil.com>2019-10-21 18:09:02 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-21 18:12:06 +0200
commitf6a0be2f99a85f90637e57657ad078c7255949ef (patch)
tree263f921d7decdb03621db8cd9fc075a5a4934b0b
parentff093d7b7b63f616fc4551fe5ca9a3e76d752ebf (diff)
downloadguix-f6a0be2f99a85f90637e57657ad078c7255949ef.tar
guix-f6a0be2f99a85f90637e57657ad078c7255949ef.tar.gz
gnu: Add gens-gs.
* gnu/packages/emulators.scm (gens-gs): New variable.
-rw-r--r--gnu/packages/emulators.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 2907cc3fcc..8095d3c44d 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -85,6 +86,7 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages web)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu))
(define-public desmume
@@ -1422,3 +1424,41 @@ functions. The source code to MAME serves as this documentation.")
"A PlayStation emulator based on PCSX-df Project with bugfixes and
improvements.")
(license license:gpl2+))))
+
+(define-public gens-gs
+ (package
+ (name "gens-gs")
+ (version "7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://retrocdn.net/images/6/6d/Gens-gs-r"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ha5s6d3y7s9aq9f4zmn9p88109c3mrj36z2w68jhiw5xrxws833"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:system "i686-linux"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-CFLAGS
+ (lambda* _
+ ;; Remove GTK API deprecation flags that cause build errors.
+ (substitute* "configure"
+ (("GTK_CFLAGS=\"\\$GTK_CFLAGS .*\"") ""))
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("nasm" ,nasm)))
+ (inputs
+ `(("sdl" ,sdl)
+ ("gtk" ,gtk+-2)))
+ (home-page "https://segaretro.org/Gens/GS")
+ (synopsis "Emulator for Sega Genesis/Mega Drive systems")
+ (description
+ "Gens/GS is an emulator for the Mega Drive (also known as Sega Genesis),
+derived from Gens. Project goals include clean source code, combined features
+from various forks of Gens, and improved platform portability.")
+ (supported-systems '("i686-linux" "x86_64-linux"))
+ (license license:gpl2+)))