aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReza Alizadeh Majd <r.majd@pantherx.org>2019-10-13 20:55:21 +0330
committerLudovic Courtès <ludo@gnu.org>2019-10-20 23:26:50 +0200
commitc10c77a795a39a72be722c4c516684853a00f2df (patch)
tree224a63ec2fd0e82edb8856957bbd038b8b10bf1b
parent79c03e55e26d88c8d327daced02367abe7f17f91 (diff)
downloadguix-c10c77a795a39a72be722c4c516684853a00f2df.tar
guix-c10c77a795a39a72be722c4c516684853a00f2df.tar.gz
gnu: Add lxqt-connman-applet.
* gnu/packages/lxqt.scm (lxqt-connman-applet) New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/lxqt.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index e5487d3ae4..8d5d3522ec 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -1279,6 +1279,52 @@ easily publishing them on internet image hosting services.")
like @command{tar} and @command{zip}.")
(license license:gpl2+)))
+(define-public lxqt-connman-applet
+ ;; since the main developers didn't release any version yet, their
+ ;; latest commit on `master` branch at the moment used for this version.
+ (let ((commit "3db374eebd8d851f68a50fc5d1ef5fa9478c275e")
+ (revision "0"))
+ (package
+ (name "lxqt-connman-applet")
+ (version (git-version "0.14.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/lxqt/" name ".git"))
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "1brkyzjmpa7hiv8p8rvmkcgagchh2zn71ry4pjiplga05as3jc11"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("liblxqt" ,liblxqt)
+ ("qtx11extras" ,qtx11extras)
+ ("libqtxdg" ,libqtxdg)))
+ (native-inputs
+ `(("lxqt-build-tools" ,lxqt-build-tools)
+ ("qtlinguist" ,qttools)))
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations"))
+ (("\\$\\{LXQT_ETC_XDG_DIR\\}") "etc/xdg"))
+ #t)))))
+ (home-page "https://github.com/lxqt/lxqt-connman-applet")
+ (synopsis "System-tray applet for connman")
+ (description "This package provides a Qt-based system-tray applet for
+the network management tool Connman, originally developed for the LXQT
+desktop.")
+ (license license:lgpl2.1+))))
+
;; The LXQt Desktop Environment
(define-public lxqt