aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-10-22 07:23:07 +0100
committerChristopher Baines <mail@cbaines.net>2019-10-22 07:27:14 +0100
commit9d67480adf0d4cbfe82183f949065c8be1e39882 (patch)
tree10eb56bfc957f55e30df1113c03f5ee4b672cb22
parent8ce774a54bfc8897a10eb21cde4649069ee06a82 (diff)
downloadguix-9d67480adf0d4cbfe82183f949065c8be1e39882.tar
guix-9d67480adf0d4cbfe82183f949065c8be1e39882.tar.gz
gnu: mongodb: Fix build.
* gnu/packages/databases.scm (mongodb)[inputs]: Use openssl 1, as 1.1. doesn't work. [arguments]: Change how a constant is defined in the tests to allow compiling with a newer version of GCC.
-rw-r--r--gnu/packages/databases.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index bfed9dff67..5c9435ae82 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -498,7 +498,7 @@ replacement for the code@{python-memcached} library.")
(search-patch "mongodb-support-unknown-linux-distributions.patch")))))
(build-system scons-build-system)
(inputs
- `(("openssl" ,openssl)
+ `(("openssl" ,openssl-1.0)
("pcre" ,pcre)
,@(match (%current-system)
((or "x86_64-linux" "aarch64-linux" "mips64el-linux")
@@ -538,6 +538,15 @@ replacement for the code@{python-memcached} library.")
,(format #f "--jobs=~a" (parallel-job-count))
"--ssl")))
(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ ;; Remove use of GNU extensions in parse_number_test.cpp, to
+ ;; allow compiling with GCC 7 or later
+ ;; https://jira.mongodb.org/browse/SERVER-28063
+ (substitute* "src/mongo/base/parse_number_test.cpp"
+ (("0xabcab\\.defdefP-10")
+ "687.16784283419838"))
+ #t))
(add-after 'unpack 'scons-propagate-environment
(lambda _
;; Modify the SConstruct file to arrange for