aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-21 01:22:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-21 02:03:22 +0200
commit4de93b2fbcfce7cd7d381c36d0059d5b018e69f6 (patch)
tree3ef355151f97213912bcb22a58d7e562b30f06ea
parentd2e1a0ac92e68d59e1828c6231ccd9ef264b87dd (diff)
downloadguix-4de93b2fbcfce7cd7d381c36d0059d5b018e69f6.tar
guix-4de93b2fbcfce7cd7d381c36d0059d5b018e69f6.tar.gz
gnu: bpython: Update to 0.18.
* gnu/packages/python-xyz.scm (bpython): Update to 0.18.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e81a6b838a..fefd3f67fa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14854,14 +14854,13 @@ Included are implementations of:
(define-public bpython
(package
(name "bpython")
- (version "0.17.1")
+ (version "0.18")
(source
(origin
(method url-fetch)
(uri (pypi-uri "bpython" version))
(sha256
- (base32
- "0bxhxi5zxdkrf8b4gwn0d363kdz3qnypjwhm1aydki53ph8ca1w9"))))
+ (base32 "1hl6frgvr2lqaxqczl8amg9xih32b3gzv429vs0qrjb8wpdj1k2n"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -14884,10 +14883,10 @@ Included are implementations of:
(propagated-inputs
`(("python-pygments" ,python-pygments)
("python-requests" ,python-requests)
- ("python-babel" ,python-babel) ; optional, for internationalization
+ ("python-babel" ,python-babel) ; optional, for internationalization
("python-curtsies" ,python-curtsies) ; >= 0.1.18
("python-greenlet" ,python-greenlet)
- ("python-urwid" ,python-urwid) ; for bpython-urwid only
+ ("python-urwid" ,python-urwid) ; for bpython-urwid only
("python-six" ,python-six)))
(native-inputs
`(("python-sphinx" ,python-sphinx)