aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-10-21 10:48:29 -0700
committerBrian Leung <leungbk@mailfence.com>2019-10-21 10:53:08 -0700
commit05b0b050bce644d96ed2222b7d88414f50bb23d9 (patch)
treec887305248f346970836dd28cf0f0978b56dd833
parent4e0703279113cc3ee0816f871beeff3282b5f94e (diff)
downloadguix-05b0b050bce644d96ed2222b7d88414f50bb23d9.tar
guix-05b0b050bce644d96ed2222b7d88414f50bb23d9.tar.gz
gnu: Add emacs-auth-source-pass.
* gnu/packages/emacs-xyz.scm (emacs-auth-source-pass): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bbcf65489e..8c3c50efdc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11602,6 +11602,34 @@ close, copy, cut, paste, undo, redo.")
standard Unix password manager\").")
(license license:gpl2+)))
+(define-public emacs-auth-source-pass
+ (let ((commit "847a1f54ed48856b4dfaaa184583ef2c84173edf")
+ (revision "1"))
+ (package
+ (name "emacs-auth-source-pass")
+ (version (git-version "5.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NicolasPetton/auth-password-store.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0g48z5w6n3c54zqfpx65dfyl9jqbl15idvbb1hhw2pd9f9r8fykk"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch"
+ "-L" "."
+ "-l" "test/auth-source-pass-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (home-page "https://github.com/NicolasPetton/auth-password-store")
+ (synopsis "Integrate @code{auth-source} with @code{password-store}")
+ (description "This package helps Emacs integrate with the Unix
+@code{password-store} application.")
+ (license license:gpl3+))))
+
(define-public emacs-pass
(package
(name "emacs-pass")