aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-07-27 15:13:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-27 15:30:38 +0200
commited2dfe3955f0144bc858c66fdb751f51e9bd84fe (patch)
tree5e8fdebcf590d21cc62db8400426e93dd44405dc
parent269f100330cf92afdc911bbd7db0644719d6dc3f (diff)
downloadguix-ed2dfe3955f0144bc858c66fdb751f51e9bd84fe.tar
guix-ed2dfe3955f0144bc858c66fdb751f51e9bd84fe.tar.gz
gnu: Add snakemake-4.
* gnu/packages/python.scm (snakemake-4): New variable. * gnu/packages/bioinformatics.scm (pigx-bsseq, pigx-rnaseq, pigx-scrnaseq, pigx-chipseq)[inputs]: Use it.
-rw-r--r--gnu/packages/bioinformatics.scm8
-rw-r--r--gnu/packages/python.scm18
2 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 73cca16717..bb0e8c73c7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12837,7 +12837,7 @@ once. This package provides tools to perform Drop-seq analyses.")
#t)))))
(inputs
`(("gzip" ,gzip)
- ("snakemake" ,snakemake)
+ ("snakemake" ,snakemake-4)
("fastqc" ,fastqc)
("multiqc" ,multiqc)
("star" ,star)
@@ -12931,7 +12931,7 @@ expression report comparing samples in an easily configurable manner.")
("fastqc" ,fastqc)
("bowtie" ,bowtie)
("idr" ,idr)
- ("snakemake" ,snakemake)
+ ("snakemake" ,snakemake-4)
("samtools" ,samtools)
("bedtools" ,bedtools)
("kentutils" ,kentutils)))
@@ -12992,7 +12992,7 @@ in an easily configurable manner.")
("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc-with-pandoc-1)
("python-wrapper" ,python-wrapper)
("python-pyyaml" ,python-pyyaml)
- ("snakemake" ,snakemake)
+ ("snakemake" ,snakemake-4)
("bismark" ,bismark)
("fastqc" ,fastqc)
("bowtie" ,bowtie)
@@ -13041,7 +13041,7 @@ methylation and segmentation.")
("python-loompy" ,python-loompy)
("ghc-pandoc" ,ghc-pandoc-1)
("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc-with-pandoc-1)
- ("snakemake" ,snakemake)
+ ("snakemake" ,snakemake-4)
("star" ,star)
("r-minimal" ,r-minimal)
("r-argparser" ,r-argparser)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a6e3ebb9d6..e9fb9f529f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5206,6 +5206,24 @@ providing a clean and modern domain specific specification language (DSL) in
Python style, together with a fast and comfortable execution environment.")
(license license:expat)))
+;; This is currently needed for the pigx-* packages.
+(define-public snakemake-4
+ (package (inherit snakemake)
+ (version "4.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "snakemake" version))
+ (sha256
+ (base32 "0g0paia4z7w3srnqdmavq3hrb2x7qnpf81jx50njl0p7y4y0j8jv"))))
+ (propagated-inputs
+ `(("python-wrapt" ,python-wrapt)
+ ("python-requests" ,python-requests)
+ ("python-appdirs" ,python-appdirs)
+ ("python-configargparse" ,python-configargparse)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-ratelimiter" ,python-ratelimiter)))))
+
(define-public python-pyqrcode
(package
(name "python-pyqrcode")