aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-07-24 23:13:50 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-07-26 15:54:52 +0200
commitd38755cb91952b574c1a72b7ea0ae8b52bc4f6e3 (patch)
tree29f938d3f685f999a29dda0be0b42b64e56e5bc4
parent714b49f68db9d8ec12fb1e006b8fa8778bdf64ee (diff)
downloadguix-d38755cb91952b574c1a72b7ea0ae8b52bc4f6e3.tar
guix-d38755cb91952b574c1a72b7ea0ae8b52bc4f6e3.tar.gz
gnu: Add ruby-net-scp.
* gnu/packages/ruby.scm (ruby-net-scp): New variable.
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6b85fe68e3..aa4cae6f97 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1849,6 +1849,32 @@ with processes on remote servers, via SSH2.")
(home-page "https://github.com/net-ssh/net-ssh")
(license license:expat)))
+(define-public ruby-net-scp
+ (package
+ (name "ruby-net-scp")
+ ;; The 1.2.1 release would be incompatible with ruby-net-ssh >= 4.
+ (version "1.2.2.rc2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/net-ssh/net-scp/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0xyf17mhgvyz54xjj9ria4wnq3x62bhmkfgzqv8jwiip2bplv1nk"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-test-unit" ,ruby-test-unit)
+ ("ruby-mocha" ,ruby-mocha)))
+ (propagated-inputs
+ `(("ruby-net-ssh" ,ruby-net-ssh)))
+ (synopsis "Pure-Ruby SCP client library")
+ (description "@code{Net::SCP} is a pure-Ruby implementation of the SCP
+client protocol.")
+ (home-page "https://github.com/net-ssh/net-scp")
+ (license license:expat)))
+
(define-public ruby-minitest
(package
(name "ruby-minitest")