aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-26 13:20:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-26 13:21:05 +0300
commitbca72b39c7548ac861d904f6230ef2c3a0fb0110 (patch)
treea7e61aee720838f75df165b1e08703d3928cf5bd
parent54e543b62632c5e977c8755c9fec3b4eb8a61860 (diff)
downloadguix-bca72b39c7548ac861d904f6230ef2c3a0fb0110.tar
guix-bca72b39c7548ac861d904f6230ef2c3a0fb0110.tar.gz
gnu: python-qsintilla: Fix building.
* gnu/packages/qt.scm (python-qscintilla)[arguments]: Extend custom 'configure phase to also patch the 'installed.txt' file.
-rw-r--r--gnu/packages/qt.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 19dc6353f2..cefceb6b68 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1959,6 +1959,10 @@ indicators, code completion and call tips.")
"Qsci/Makefile")
(("\\$\\(INSTALL_ROOT\\)/gnu/store/[^/]+")
(assoc-ref outputs "out")))
+ ;; And fix the installed.txt file
+ (substitute* "installed.txt"
+ (("/gnu/store/[^/]+")
+ (assoc-ref outputs "out")))
#t)))))
(inputs
`(("qscintilla" ,qscintilla)