aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-22 18:53:04 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-22 21:43:38 +0200
commit9630ae345bf165704eb0de47c788cb70f5bf0d53 (patch)
treec5af9e7e96efde11392a83a3ddd3165e3324513e
parentbc3138d265dd31ca27b89b41d6c126fa8367547f (diff)
downloadguix-9630ae345bf165704eb0de47c788cb70f5bf0d53.tar
guix-9630ae345bf165704eb0de47c788cb70f5bf0d53.tar.gz
gnu: Add go-github-com-michiwend-golang-pretty.
* gnu/packages/golang.scm (go-github-com-michiwend-golang-pretty): New variable.
-rw-r--r--gnu/packages/golang.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0092c2ace2..d0b6c25502 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2266,3 +2266,37 @@ be performed.")
(description "Package @code{text} provides manipulation Go functions for
paragraphs of text.")
(license license:expat))))
+
+(define-public go-github-com-michiwend-golang-pretty
+ (let ((commit "8ac61812ea3fa540f3f141a444fcb0dd713cdca4")
+ (revision "0"))
+ (package
+ (name "go-github-com-michiwend-golang-pretty")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/michiwend/golang-pretty")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rjfms0csjqi91xnddzx3rcrcaikc7xc027617px3kdwdap80ir4"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-github-com-kr-text" ,go-github-com-kr-text)))
+ (arguments
+ `(#:tests? #f ; Upstream tests seem to be broken.
+ #:import-path "github.com/michiwend/golang-pretty"))
+ (home-page "https://github.com/michiwend/golang-pretty")
+ (synopsis "Pretty printing for Go values")
+ (description "Package @code{pretty} provides pretty-printing for Go
+values. This is useful during debugging, to avoid wrapping long output lines
+in the terminal.
+
+It provides a function, @code{Formatter}, that can be used with any function
+that accepts a format string. It also provides convenience wrappers for
+functions in packages @code{fmt} and @code{log}.")
+ (license license:expat))))