aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-19 21:16:43 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-25 11:52:59 +0300
commit8e1895964fd10fbf5f19ad39ca080f684a6246d6 (patch)
tree8c6cfc0af8edef1b5c6c04d244ea527da4ff43c5
parent39a57afc42d473517f6e62c2d6a5d3c75eee3e89 (diff)
downloadguix-8e1895964fd10fbf5f19ad39ca080f684a6246d6.tar
guix-8e1895964fd10fbf5f19ad39ca080f684a6246d6.tar.gz
gnu: Add hplip-minimal.
* gnu/packages/cups.scm (hplip-minimal): New variable. * gnu/packages/scanner.scm (sane-backends)[inputs]: Replace hplip with hplip-minimal. * doc/guix.texi (Printing Services): Change example code to use hplip-minimal in place of hplip. Add note explaining when use hplip.
-rw-r--r--doc/guix.texi8
-rw-r--r--gnu/packages/cups.scm19
-rw-r--r--gnu/packages/scanner.scm3
3 files changed, 25 insertions, 5 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index f9b3ef0e55..2df4064524 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -12156,7 +12156,7 @@ secure connections to the print server.
Suppose you want to enable the Web interface of CUPS and also add
support for Epson printers @i{via} the @code{escpr} package and for HP
-printers @i{via} the @code{hplip} package. You can do that directly,
+printers @i{via} the @code{hplip-minimal} package. You can do that directly,
like this (you need to use the @code{(gnu packages cups)} module):
@example
@@ -12164,9 +12164,13 @@ like this (you need to use the @code{(gnu packages cups)} module):
(cups-configuration
(web-interface? #t)
(extensions
- (list cups-filters escpr hplip))))
+ (list cups-filters escpr hplip-minimal))))
@end example
+Note: If you wish to use the Qt5 based GUI which comes with the hplip
+package then it is suggested that you install the @code{hplip} package,
+either in your OS configuration file or as your user.
+
The available configuration parameters follow. Each parameter
definition is preceded by its type; for example, @samp{string-list foo}
indicates that the @code{foo} parameter should be specified as a list of
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index bfc587a6fb..04d4e3fadd 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
@@ -46,7 +46,9 @@
#:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages))
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (srfi srfi-1))
(define-public cups-filters
(package
@@ -520,6 +522,19 @@ device-specific programs to convert and print many types of files.")
`(("perl" ,perl)
("pkg-config" ,pkg-config)))))
+(define-public hplip-minimal
+ (package
+ (inherit hplip)
+ (name "hplip-minimal")
+ (arguments
+ (substitute-keyword-arguments (package-arguments hplip)
+ ((#:configure-flags cf)
+ ``(,@(delete "--enable-qt5" ,cf)))))
+ (inputs
+ `(,@(fold alist-delete (package-inputs hplip)
+ '("python-pygobject" "python-pyqt"))))
+ (synopsis "GUI-less version of hplip")))
+
(define-public foomatic-filters
(package
(name "foomatic-filters")
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index 33a573d531..d030d8ade5 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -102,7 +103,7 @@ package contains the library, but no drivers.")
(inherit sane-backends-minimal)
(name "sane-backends")
(inputs
- `(("hplip" ,(@ (gnu packages cups) hplip))
+ `(("hplip" ,(@ (gnu packages cups) hplip-minimal))
,@(package-inputs sane-backends-minimal)))
(arguments
(substitute-keyword-arguments (package-arguments sane-backends-minimal)