aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-07-27 15:07:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-27 15:30:38 +0200
commit216a72a95738d6d643094f156000cbc006cd79f5 (patch)
tree2dbec070ad3231153dd75b947b1d659ad95cbe0b
parentbeb8511c7346ec9a7e0a354035230f494b7d44e2 (diff)
downloadguix-216a72a95738d6d643094f156000cbc006cd79f5.tar
guix-216a72a95738d6d643094f156000cbc006cd79f5.tar.gz
gnu: Add python-datrie.
* gnu/packages/python.scm (python-datrie): New variable.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f20de13720..1422ad26a3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5136,6 +5136,30 @@ of the structure, dynamics, and functions of complex networks.")
(define-public python2-networkx2
(package-with-python2 python-networkx2))
+(define-public python-datrie
+ (package
+ (name "python-datrie")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "datrie" version))
+ (sha256
+ (base32
+ "08r0if7dry2q7p34gf7ffyrlnf4bdvnprxgydlfxgfnvq8f3f4bs"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-cython" ,python-cython)
+ ("python-hypothesis" ,python-hypothesis)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/kmike/datrie")
+ (synopsis "Fast, efficiently stored trie for Python")
+ (description
+ "This package provides a fast, efficiently stored trie implementation for
+Python.")
+ (license license:lgpl2.1+)))
+
(define-public snakemake
(package
(name "snakemake")