aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2018-07-21 10:23:55 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-07-25 00:27:10 +0200
commit10d62a88bf1b33f1f4df9d3d0b4721bd5f5cd70b (patch)
treee3d5aa3207fb6927b3e278d6543331fe0065cc77
parent10eddaca0e0012fd6894ae9c5d59eaf4d0efa351 (diff)
downloadguix-10d62a88bf1b33f1f4df9d3d0b4721bd5f5cd70b.tar
guix-10d62a88bf1b33f1f4df9d3d0b4721bd5f5cd70b.tar.gz
gnu: Add java-javaee-servletapi.
* gnu/packages/java.scm (java-javaee-servletapi): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/java.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d6c88f56be..b60aeddea2 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2537,6 +2537,37 @@ ClasspathX project. It provides implementations of version 3.0 of the servlet
API and version 2.1 of the Java ServerPages API.")
(license license:gpl3+)))
+(define-public java-javaee-servletapi
+ (package
+ (name "java-javaee-servletapi")
+ (version "3.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/javaee/servlet-spec/"
+ "archive/" version ".zip"))
+ (file-name (string-append name "-" version ".zip"))
+ (sha256
+ (base32
+ "0m6p13vgfb1ihich1jp5j6fqlhkjsrkn32c86bsbkryp38ipwg8w"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "javax-servletapi.jar"
+ ;; no tests
+ #:tests? #f
+ #:source-dir "src/main/java"))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (home-page "https://javaee.github.io/servlet-spec/")
+ (synopsis "Java servlet API")
+ (description "Java Servlet is the foundation web specification in the
+Java Enterprise Platform. Developers can build web applications using the
+Servlet API to interact with the request/response workflow. This project
+provides information on the continued development of the Java Servlet
+specification.")
+ ;; Main code is dual-licensed by Oracle under either GLP2 or CDDL 1.1.
+ ;; Some files are licensed under ASL 2.0.
+ (license (list license:asl2.0 license:gpl2 license:cddl1.1))))
+
(define-public java-swt
(package
(name "java-swt")