aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornee <nee.git@cock.li>2017-11-25 20:51:11 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-26 17:36:26 +0100
commit1ee13e01c8a9e5f1ee87c580d283cf6fea7d80dc (patch)
treee3dada358fa4afc59dbfcdf3ba2d3b5c9fab6320
parent9b0713012905f3997d6fad201dba7c3d93b38b13 (diff)
downloadguix-1ee13e01c8a9e5f1ee87c580d283cf6fea7d80dc.tar
guix-1ee13e01c8a9e5f1ee87c580d283cf6fea7d80dc.tar.gz
gnu: image: Rename pngcrunch to pngcrush and update it.
* gnu/packages/image.scm (pngcrush): Renamed from pngcrunch. [version]: update to 1.8.13. [arguments]: Use the nolib Makefile. [origin]: Use the no-lib tar. [home-page]: update to the new website. (pngcrunch): New deprecation variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/image.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index cb8e387f6a..a183817dbd 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -207,25 +207,24 @@ in-memory raw vectors.")
;; Any of these GPL versions.
(license (list license:gpl2 license:gpl3))))
-(define-public pngcrunch
+(define-public pngcrush
(package
- (name "pngcrunch")
- (version "1.8.11")
+ (name "pngcrush")
+ (version "1.8.13")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/pmt/pngcrush/"
- version "/pngcrush-" version ".tar.xz"))
+ version "/pngcrush-" version "-nolib.tar.xz"))
(sha256 (base32
- "1c7m316i91jp3h1dj1ppppdv6zilm2njk1wrpqy2zj0fcll06lwd"))))
+ "0l43c59d6v9l0g07z3q3ywhb8xb3vz74llv3mna0izk9bj6aqkiv"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags '("-f" "Makefile-nolib")
- #:tests? #f ; no check target
+ '(#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "Makefile-nolib"
+ (substitute* "Makefile"
(("^(PNG(INC|LIB) = )/usr/local/" line vardef)
(string-append vardef (assoc-ref inputs "libpng") "/"))
(("^(Z(INC|LIB) = )/usr/local/" line vardef)
@@ -236,12 +235,16 @@ in-memory raw vectors.")
(inputs
`(("libpng" ,libpng)
("zlib" , zlib)))
- (home-page "https://pmt.sourceforge.net/pngcrush")
+ (home-page "https://pmt.sourceforge.io/pngcrush")
(synopsis "Utility to compress PNG files")
(description "pngcrusqh is an optimizer for PNG (Portable Network Graphics)
files. It can compress them as much as 40% losslessly.")
(license license:zlib)))
+(define-public pngcrunch
+ ;; This package used to be wrongfully name "pngcrunch".
+ (deprecated-package "pngcrunch" pngcrush))
+
(define-public libjpeg
(package
(name "libjpeg")