aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-09 11:20:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-09 11:20:22 +0100
commitd8f46d52343972af6734c28cce94559e1c78481f (patch)
tree342b4488a91ad0c50662f96f4f83055c4ca91366
parent1b5905fe689716e73ad7defc1bf8c6a13966f3c1 (diff)
downloadguix-d8f46d52343972af6734c28cce94559e1c78481f.tar
guix-d8f46d52343972af6734c28cce94559e1c78481f.tar.gz
gnu: hdf5: Do not record the build-time kernel version.
* gnu/packages/maths.scm (hdf5)[arguments]: Patch libhdf5.settings to prevent the kernel version on the build node from affecting the output.
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8d0c10697f..cf3d8ae836 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -724,7 +724,11 @@ incompatible with HDF5.")
;; unnecessary store references to those compilers:
(substitute* "src/libhdf5.settings"
(("(/gnu/store/)([a-Z0-9]*)" all prefix hash)
- (string-append prefix (string-take hash 10) "...")))
+ (string-append prefix (string-take hash 10) "..."))
+ ;; Don't record the build-time kernel version to make the
+ ;; settings file reproducible.
+ (("Uname information:.*")
+ "Uname information: Linux\n"))
#t))
(add-after 'install 'patch-references
(lambda* (#:key inputs outputs #:allow-other-keys)