aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-08 23:29:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-08 23:31:56 +0100
commitd10b0952ce6be1c4f172b21622184e59bb3e1020 (patch)
tree386fa3df8c019057e87e8ca86b23a79340d34548
parent661bb51e668a239372dbc4df582b73ca356e38bc (diff)
downloadguix-d10b0952ce6be1c4f172b21622184e59bb3e1020.tar
guix-d10b0952ce6be1c4f172b21622184e59bb3e1020.tar.gz
gnu: Add r-fnn.
* gnu/packages/cran.scm (r-fnn): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index efb612e34f..81b791d346 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3146,3 +3146,26 @@ data including missing values. In addition, the quality of imputation can be
visually explored using various univariate, bivariate, multiple and
multivariate plot methods.")
(license license:gpl2+)))
+
+(define-public r-fnn
+ (package
+ (name "r-fnn")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "FNN" version))
+ (sha256
+ (base32
+ "1kncmiaraq1mrykb9fj3fsxswabk3l71fnp1vks0x9aay5xfk8mj"))))
+ (properties `((upstream-name . "FNN")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/FNN")
+ (synopsis "Fast nearest neighbor search algorithms and applications")
+ (description
+ "This package provides cover-tree and kd-tree fast k-nearest neighbor
+search algorithms. Related applications including KNN classification,
+regression and information measures are implemented.")
+ ;; The DESCRIPTION file erroneously states that GPL version 2.1 or
+ ;; later can be used.
+ (license license:gpl2+)))