aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-08 23:12:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-08 23:14:10 +0100
commitbbf8540d43bf84349fa1c002b2d1c42ebcc02636 (patch)
treed3e914fc8836662733da894a713fb72a448dfaef
parent1f3921e1435db7c9489f22832554ad4692434efc (diff)
downloadguix-bbf8540d43bf84349fa1c002b2d1c42ebcc02636.tar
guix-bbf8540d43bf84349fa1c002b2d1c42ebcc02636.tar.gz
gnu: python-sympy, python2-sympy: Only run core tests.
* gnu/packages/python.scm (python-sympy, python2-sympy)[arguments]: Move tests after installation; run only core tests.
-rw-r--r--gnu/packages/python.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 73b0e91327..c454539fef 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5066,6 +5066,17 @@ more advanced mathematics.")
(sha256
(base32 "190n29sppw7g8ihilc5451y7jlfcaw56crqiqbf1jff43dlmfnxc"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Run the core tests after installation. By default it would run
+ ;; *all* tests, which take a very long time to complete and are known
+ ;; to be flaky.
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "python3" "-c" "import sympy; sympy.test(\"/core\")")
+ #t)))))
(propagated-inputs
`(("python-mpmath" ,python-mpmath)))
(home-page "http://www.sympy.org/")
@@ -5077,7 +5088,19 @@ as possible in order to be comprehensible and easily extensible.")
(license license:bsd-3)))
(define-public python2-sympy
- (package-with-python2 python-sympy))
+ (package
+ (inherit (package-with-python2 python-sympy))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Run the core tests after installation. By default it would run
+ ;; *all* tests, which take a very long time to complete and are known
+ ;; to be flaky.
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "python" "-c" "import sympy; sympy.test(\"/core\")")
+ #t)))))))
(define-public python-q
(package