aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-08 23:29:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-08 23:31:56 +0100
commit661bb51e668a239372dbc4df582b73ca356e38bc (patch)
tree91be226c8c497232dc19b55695ad9b318e5e9395
parentfc784b6672eb8d21e1cb52dda1fd32c1bc4ae9a2 (diff)
downloadguix-661bb51e668a239372dbc4df582b73ca356e38bc.tar
guix-661bb51e668a239372dbc4df582b73ca356e38bc.tar.gz
gnu: Add r-vim.
* gnu/packages/cran.scm (r-vim): New variable.
-rw-r--r--gnu/packages/cran.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4b63c0f644..efb612e34f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3108,3 +3108,41 @@ curve is done by a non-linear piecewise function. In addition to the areas
under the curves, the curves themselves can also be computed and plotted by a
specific S3-method.")
(license license:gpl3)))
+
+(define-public r-vim
+ (package
+ (name "r-vim")
+ (version "4.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "VIM" version))
+ (sha256
+ (base32
+ "1vjcs5wvjv94ln01d94h9rs4j50d3ky4n26mm3prgh13raylrmnd"))))
+ (properties `((upstream-name . "VIM")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-car" ,r-car)
+ ("r-colorspace" ,r-colorspace)
+ ("r-data-table" ,r-data-table)
+ ("r-e1071" ,r-e1071)
+ ("r-laeken" ,r-laeken)
+ ("r-mass" ,r-mass)
+ ("r-nnet" ,r-nnet)
+ ("r-rcpp" ,r-rcpp)
+ ("r-robustbase" ,r-robustbase)
+ ("r-sp" ,r-sp)
+ ("r-vcd" ,r-vcd)))
+ (home-page "https://github.com/alexkowa/VIM")
+ (synopsis "Visualization and imputation of missing values")
+ (description
+ "This package provides tools for the visualization of missing and/or
+imputed values are introduced, which can be used for exploring the data and
+the structure of the missing and/or imputed values. Depending on this
+structure of the missing values, the corresponding methods may help to
+identify the mechanism generating the missing values and allows to explore the
+data including missing values. In addition, the quality of imputation can be
+visually explored using various univariate, bivariate, multiple and
+multivariate plot methods.")
+ (license license:gpl2+)))