aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-08 23:29:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-08 23:31:56 +0100
commit22a0c6596921b87dd8cc38dfbdf99e13ae719a7d (patch)
treeef7f5538a663570bb0964be737ab982068ed9c53
parentbe815dbdda155e1e920667a1c34bf264cb20f5b3 (diff)
downloadguix-22a0c6596921b87dd8cc38dfbdf99e13ae719a7d.tar
guix-22a0c6596921b87dd8cc38dfbdf99e13ae719a7d.tar.gz
gnu: Add r-phangorn.
* gnu/packages/bioinformatics.scm (r-phangorn): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a5ad2c57e7..92549d3c75 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10853,6 +10853,34 @@ are optimized per data type and for subsetted calculations such that both
memory usage and processing time is minimized.")
(license license:expat)))
+(define-public r-phangorn
+ (package
+ (name "r-phangorn")
+ (version "2.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "phangorn" version))
+ (sha256
+ (base32
+ "0xc8k552nxczy19jr0xjjagrzc8x6lafasgk2c099ls8bc1yml1i"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ape" ,r-ape)
+ ("r-fastmatch" ,r-fastmatch)
+ ("r-igraph" ,r-igraph)
+ ("r-magrittr" ,r-magrittr)
+ ("r-matrix" ,r-matrix)
+ ("r-quadprog" ,r-quadprog)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/KlausVigo/phangorn")
+ (synopsis "Phylogenetic analysis in R")
+ (description
+ "Phangorn is a package for phylogenetic analysis in R. It supports
+estimation of phylogenetic trees and networks using Maximum Likelihood,
+Maximum Parsimony, distance methods and Hadamard conjugation.")
+ (license license:gpl2+)))
+
(define-public r-dropbead
(let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
(revision "2"))