aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-12-12 23:23:32 -0500
committerMark H Weaver <mhw@netris.org>2019-04-22 14:58:24 -0400
commitdf129041dd7cf0f25e5d256b19bb2b383abcf600 (patch)
treef36249271ecf55c49a0ece7c03190b767ff830af
parentfa9e6e8b676ca920a894cf3b48bfcb670077144f (diff)
downloadguix-df129041dd7cf0f25e5d256b19bb2b383abcf600.tar
guix-df129041dd7cf0f25e5d256b19bb2b383abcf600.tar.gz
gnu: maxima: Return #t from custom 'check' phase.
* gnu/packages/maths.scm (maxima)[arguments]: Use invoke in the custom check phase.
-rw-r--r--gnu/packages/maths.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 373b99727d..6e2c10d93a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
-;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
@@ -2795,12 +2795,12 @@ to BMP, JPEG or PNG image formats.")
;; of Debian's Maxima package.
;; If Maxima can successfully run this, the binary to be installed
;; should be fine.
- (zero?
- (system
- (string-append "./maxima-local "
- "--lisp=gcl "
- "--batch-string=\"run_testsuite();\" "
- "| grep -q \"No unexpected errors found\"")))))
+ (invoke "sh" "-c"
+ (string-append
+ "./maxima-local "
+ "--lisp=gcl "
+ "--batch-string=\"run_testsuite();\" "
+ "| grep -q \"No unexpected errors found\""))))
;; Make sure the doc and emacs files are found in the
;; standard location. Also configure maxima to find gnuplot
;; without having it on the PATH.