aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-04-21 09:48:26 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-04-21 09:48:26 +0200
commitdbcd503c46f769c3ac70d0ad1d72071c7015574e (patch)
tree8e34ca4710c606ddf81902530eff6588459b2095
parent442a11f68f141264283a9eee0e0e15bebe104cf8 (diff)
downloadguix-dbcd503c46f769c3ac70d0ad1d72071c7015574e.tar
guix-dbcd503c46f769c3ac70d0ad1d72071c7015574e.tar.gz
gnu: guile-parted: Update to 0.0.1.
* gnu/packages/guile-xyz.scm (guile-parted): Update to 0.0.1.
-rw-r--r--gnu/packages/guile-xyz.scm65
1 files changed, 31 insertions, 34 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 125b6a5785..03fd63837e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1009,42 +1009,39 @@ Scheme by using Guileā€™s foreign function interface.")
microblogging service.")
(license license:gpl3+)))
-;; There has not been any release yet.
(define-public guile-parted
- (let ((commit "ea3f1a1f6844775fc59d3078d2a09c62ffb341b8")
- (revision "0"))
- (package
- (name "guile-parted")
- (version (string-append "0-" revision "." (string-take commit 9)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/mothacehe/guile-parted")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1q7425gpjlwi2wvhzq7kw046yyx7v6j6jyzkd1cr861iz34mjwiq"))))
- (build-system gnu-build-system)
- (arguments
- '(#:make-flags
- '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
- (inputs
- `(("guile" ,guile-2.2)
- ("parted" ,parted)))
- (propagated-inputs
- `(("guile-bytestructures" ,guile-bytestructures)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)))
- (synopsis "Guile bindings to GNU Parted")
- (description
- "This package provides bindings for GNU Parted library, a C library
-allowing disk partition tables creation and manipulation. The bindings are
+ (package
+ (name "guile-parted")
+ (version "0.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/mothacehe/guile-parted")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q7425gpjlwi2wvhzq7kw046yyx7v6j6jyzkd1cr861iz34mjwiq"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags
+ '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (inputs
+ `(("guile" ,guile-2.2)
+ ("parted" ,parted)))
+ (propagated-inputs
+ `(("guile-bytestructures" ,guile-bytestructures)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Guile bindings to GNU Parted")
+ (description
+ "This package provides bindings for GNU Parted library, a C library
+allowing disk partition tables creation and manipulation. The bindings are
written in pure Scheme by using Guile's foreign function interface.")
- (home-page "https://gitlab.com/mothacehe/guile-parted")
- (license license:gpl3+))))
+ (home-page "https://gitlab.com/mothacehe/guile-parted")
+ (license license:gpl3+)))
(define-public guile-xosd
(package