aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-04-21 10:33:18 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-21 10:38:30 +0100
commit9729b6ea2fe89d5b8cfd180ef2dfca367c7417e5 (patch)
tree3ffa08206222c15031f7d0430b348e108dc334ea
parentdc01978288318a8155e2e2657be9b278a754ebac (diff)
downloadguix-9729b6ea2fe89d5b8cfd180ef2dfca367c7417e5.tar
guix-9729b6ea2fe89d5b8cfd180ef2dfca367c7417e5.tar.gz
gnu: direnv: Remove go references from output.
In the long run, it would be good to move direnv across to the go-build-system, and update the package, but these changes do succeed in reducing the closure size a lot. Thanks to Tanguy Le Carrour for raising this issue on guix-devel. * gnu/packages/shellutils.scm (direnv)[arguments]: Include the remove-go-references phase from the go-build-system. [inputs,native-inputs]: Move all inputs to native-inputs, as these are no longer referenced in the output.
-rw-r--r--gnu/packages/shellutils.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 88c0f32e99..59a8b744eb 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -128,13 +128,14 @@ are already there.")
(delete 'configure)
;; Help the build scripts find the Go language dependencies.
(add-before 'unpack 'setup-go-environment
- (assoc-ref go:%standard-phases 'setup-go-environment)))))
- (inputs
+ (assoc-ref go:%standard-phases 'setup-go-environment))
+ (add-after 'install 'remove-go-references
+ (assoc-ref go:%standard-phases 'remove-go-references)))))
+ (native-inputs
`(("go" ,go)
("go-github-com-burntsushi-toml" ,go-github-com-burntsushi-toml)
- ("go-github-com-direnv-go-dotenv" ,go-github-com-direnv-go-dotenv)))
- (native-inputs
- `(("which" ,which)))
+ ("go-github-com-direnv-go-dotenv" ,go-github-com-direnv-go-dotenv)
+ ("which" ,which)))
(home-page "https://direnv.net/")
(synopsis "Environment switcher for the shell")
(description