aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-25 14:55:26 +0200
committerRoel Janssen <roel@gnu.org>2018-04-25 14:55:26 +0200
commitd000264299864480aa8b80357a3c6ae5ff2a5e74 (patch)
tree21feece2477db688919ea6753dc775ae5c726dd9
parent5b862761f2a60af79b4c16851454a5e792ef4f56 (diff)
downloadguix-d000264299864480aa8b80357a3c6ae5ff2a5e74.tar
guix-d000264299864480aa8b80357a3c6ae5ff2a5e74.tar.gz
gnu: guile-ssh: Move files from bin to examples directory.
* gnu/packages/ssh.scm (guile-ssh): Move files from bin to the examples directory.
-rw-r--r--gnu/packages/ssh.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index afd41cd8e7..e4a277c5e6 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -259,8 +259,20 @@ Additionally, various channel-specific options can be negotiated.")
(substitute* (find-files "." "\\.scm$")
(("\"libguile-ssh\"")
(string-append "\"" libdir "/libguile-ssh\"")))
- #t)))))
-
+ #t))))
+ (add-after 'install 'remove-bin-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (examples (string-append
+ out "/share/guile-ssh/examples")))
+ (mkdir-p examples)
+ (rename-file (string-append bin "/ssshd.scm")
+ (string-append examples "/ssshd.scm"))
+ (rename-file (string-append bin "/sssh.scm")
+ (string-append examples "/sssh.scm"))
+ (delete-file-recursively bin)
+ #t))))
;; Tests are not parallel-safe.
#:parallel-tests? #f))
(native-inputs `(("autoconf" ,autoconf)