aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-04-26 09:46:37 +0200
committerRutger Helling <rhelling@mykolab.com>2018-04-26 09:51:26 +0200
commitc7fc414e1ee3f5a0fe83b765a56195cef0ac550c (patch)
tree82b6d99e6544d2e045a93e7df1bd14498b98f429
parentdcf3ab6ab301822ce06eb3ff0eee3b65a3a84335 (diff)
downloadguix-c7fc414e1ee3f5a0fe83b765a56195cef0ac550c.tar
guix-c7fc414e1ee3f5a0fe83b765a56195cef0ac550c.tar.gz
gnu: gnome-tweak-tool: Update to 3.26.4.
* gnu/packages/gnome.scm (gnome-tweak-tool): Update to 3.26.4. [arguments]: Replace 'configure, 'build, 'check and 'install phases with Meson build phases. [native-inputs]: Add "gtk+:bin", "meson" and "ninja". [inputs]: Add "nautilus." Replace "python@2" with "python" and "python2-pygobject" with "python-pygobject".
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 23 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index aac1f08978..0311621cc0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6294,7 +6294,7 @@ existing databases over the internet.")
(define-public gnome-tweak-tool
(package
(name "gnome-tweak-tool")
- (version "3.24.1")
+ (version "3.26.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gnome-tweak-tool/"
@@ -6304,7 +6304,7 @@ existing databases over the internet.")
(search-patch "gnome-tweak-tool-search-paths.patch")))
(sha256
(base32
- "0rgmm7n6jwc5hz64sprm4jxnky62hw839a7r18rn1mj884vnn8hr"))))
+ "1pq5a0kzh1sz7s7ax5c7p6212k9d51nk5bfvjfyqn99cs928187x"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:configure-flags '("--localstatedir=/tmp"
@@ -6312,6 +6312,16 @@ existing databases over the internet.")
#:imported-modules ((guix build python-build-system)
,@%glib-or-gtk-build-system-modules)
#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "meson" "build"
+ "--prefix" (assoc-ref outputs "out"))))
+ (replace 'check
+ (lambda _ (invoke "ninja" "-C" "build" "test")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "ninja" "-C" "build" "install")))
(add-after 'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -6322,17 +6332,21 @@ existing databases over the internet.")
(add-after 'install 'wrap
(@@ (guix build python-build-system) wrap)))))
(native-inputs
- `(("intltool" ,intltool)
+ `(("gtk+:bin" ,gtk+ "bin") ; For gtk-update-icon-cache
+ ("intltool" ,intltool)
+ ("meson" ,meson-for-build)
+ ("ninja" ,ninja)
("pkg-config" ,pkg-config)))
(inputs
- `(("python" ,python-2)
- ("python2-pygobject" ,python2-pygobject)
- ("gnome-desktop" ,gnome-desktop)
- ("libsoup" ,libsoup)
- ("libnotify" ,libnotify)
+ `(("gnome-desktop" ,gnome-desktop)
+ ("gtk+" ,gtk+)
("gobject-introspection" ,gobject-introspection)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtk+" ,gtk+)))
+ ("libnotify" ,libnotify)
+ ("libsoup" ,libsoup)
+ ("nautilus" ,nautilus)
+ ("python" ,python)
+ ("python-pygobject" ,python-pygobject)))
(synopsis "Customize advanced GNOME 3 options")
(home-page "https://wiki.gnome.org/action/show/Apps/GnomeTweakTool")
(description