aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-24 13:33:56 +0200
committerRoel Janssen <roel@gnu.org>2018-04-24 13:33:56 +0200
commita5b56a5346ce14c2d5f02ef3e1b4964d8dd4f8d5 (patch)
treea860fd0b7f36994784ee4a46f12c4e7bc1938373
parentbe65267f93d9c1981000b4fcbaffc477b452b568 (diff)
downloadguix-a5b56a5346ce14c2d5f02ef3e1b4964d8dd4f8d5.tar
guix-a5b56a5346ce14c2d5f02ef3e1b4964d8dd4f8d5.tar.gz
gnu: Add r-diffbind.
* gnu/packages/bioconductor.scm (r-diffbind): New variable.
-rw-r--r--gnu/packages/bioconductor.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 09581d9fde..e43b3ff928 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -23,6 +23,8 @@
#:use-module (guix download)
#:use-module (guix build-system r)
#:use-module (gnu packages)
+ #:use-module (gnu packages cran)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages statistics)
#:use-module (gnu packages bioinformatics))
@@ -70,3 +72,45 @@ the Human Protein Atlas project.")
customizable permutation tests to assess the association between genomic
region sets and other genomic features.")
(license license:artistic2.0)))
+
+(define-public r-diffbind
+ (package
+ (name "r-diffbind")
+ (version "2.6.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DiffBind" version))
+ (sha256
+ (base32
+ "1sm5h6nq77hjfis6kr1nqyizcxgfz87dgpqc4fxlfqkmsd9n3vkp"))))
+ (properties `((upstream-name . "DiffBind")))
+ (build-system r-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-amap" ,r-amap)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-deseq2" ,r-deseq2)
+ ("r-dplyr" ,r-dplyr)
+ ("r-edger" ,r-edger)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-ggrepel" ,r-ggrepel)
+ ("r-gplots" ,r-gplots)
+ ("r-iranges" ,r-iranges)
+ ("r-lattice" ,r-lattice)
+ ("r-limma" ,r-limma)
+ ("r-locfit" ,r-locfit)
+ ("r-rcolorbrewer" , r-rcolorbrewer)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-systempiper" ,r-systempiper)
+ ("r-zlibbioc" ,r-zlibbioc)))
+ (home-page "http://bioconductor.org/packages/DiffBind")
+ (synopsis "Differential binding analysis of ChIP-Seq peak data")
+ (description
+ "This package computes differentially bound sites from multiple
+ChIP-seq experiments using affinity (quantitative) data. Also enables
+occupancy (overlap) analysis and plotting functions.")
+ (license license:artistic2.0)))