aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-04-25 14:40:21 +0530
committerLudovic Courtès <ludo@gnu.org>2018-04-25 23:11:53 +0200
commita0bee5e769191705f930e07d4ed0f19273e3dec7 (patch)
treeabc2cf7439952d532adb873b23e8c3eff5e4542f
parentb889df2722c30d74402f0d14037888834702aa0c (diff)
downloadguix-a0bee5e769191705f930e07d4ed0f19273e3dec7.tar
guix-a0bee5e769191705f930e07d4ed0f19273e3dec7.tar.gz
gnu: Add emacs-evil-collection
* gnu/packages/emacs.scm (emacs-evil-collection): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4f36d73277..2c9bd68b23 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4527,6 +4527,31 @@ main features of Vim, and provides facilities for writing custom
extensions.")
(license license:gpl3+)))
+(define-public emacs-evil-collection
+ (let ((commit "f40704a57fd33b4bfad64147a2b771fc8961fdfc")
+ (revision "1"))
+ (package
+ (name "emacs-evil-collection")
+ (version (git-version "20180425" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-evil/evil-collection")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0qn19k0f3isnbi1hkmcf3qjxbyvp23m5ak5ny7623qgwb2nwz1l5"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-evil" ,emacs-evil)))
+ (home-page "https://github.com/emacs-evil/evil-collection")
+ (synopsis "Collection of Evil bindings for many major and minor modes")
+ (description "This is a collection of Evil bindings for the parts of
+Emacs that Evil does not cover properly by default, such as @code{help-mode},
+@code{M-x calendar}, Eshell and more.")
+ (license license:gpl3+))))
+
(define-public emacs-goto-chg
(package
(name "emacs-goto-chg")