aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-04-21 09:22:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-04-21 23:07:52 +0200
commit9604429d7bf76ce39b600dde120bc4b372af54a4 (patch)
tree2b60f2a1cae10feb3f263fb4c9525b192076f969
parentce4e81cb868307ab9ab84c4b07596a57ad0e57c8 (diff)
downloadguix-9604429d7bf76ce39b600dde120bc4b372af54a4.tar
guix-9604429d7bf76ce39b600dde120bc4b372af54a4.tar.gz
gnu: Add r-geometry.
* gnu/packages/cran.scm (r-geometry): New variable.
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2f4b2e5367..1c540a3c46 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1503,6 +1503,36 @@ a variety of functions for the manipulation and analysis of arbitrarily
dimensioned arrays.")
(license license:gpl2)))
+(define-public r-geometry
+ (package
+ (name "r-geometry")
+ (version "0.3-6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "geometry" version))
+ (sha256
+ (base32
+ "0s09vi0rr0smys3an83mz6fk41bplxyz4myrbiinf4qpk6n33qib"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-magic" ,r-magic)))
+ (home-page "http://geometry.r-forge.r-project.org/")
+ (synopsis "Mesh generation and surface tesselation")
+ (description
+ "This package makes the qhull library available in R, in a similar manner
+as in Octave. Qhull computes convex hulls, Delaunay triangulations, halfspace
+intersections about a point, Voronoi diagrams, furthest-site Delaunay
+triangulations, and furthest-site Voronoi diagrams. It runs in 2-d, 3-d, 4-d,
+and higher dimensions. It implements the Quickhull algorithm for computing
+the convex hull. Qhull does not support constrained Delaunay triangulations,
+or mesh generation of non-convex objects, but the package does include some R
+functions that allow for this. Currently the package only gives access to
+Delaunay triangulation and convex hull computation.")
+ ;; The Qhull sources are included and are distributed under a custom
+ ;; non-copyleft license. The R sources are released under GPL version 2.
+ (license (list license:gpl2
+ (license:non-copyleft "http://www.qhull.org/COPYING.txt")))))
+
(define-public r-ddalpha
(package
(name "r-ddalpha")