aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-24 14:12:15 +0200
committerRoel Janssen <roel@gnu.org>2018-04-24 14:12:15 +0200
commit67ee83d6c30b7b73facf1f9a7c981d05399ff190 (patch)
treefac17ffb99eba456fed4773a287a6f6e50341241
parent0416a0d4d5c38a9352d965b71d1eb9d966ed7db9 (diff)
downloadguix-67ee83d6c30b7b73facf1f9a7c981d05399ff190.tar
guix-67ee83d6c30b7b73facf1f9a7c981d05399ff190.tar.gz
gnu: Add r-cghcall.
* gnu/packages/bioconductor.scm (r-cghcall): New variable.
-rw-r--r--gnu/packages/bioconductor.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 87c0c68f33..9b1d8667a6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -275,3 +275,26 @@ normalization and quality checking.")
(description "This package contains functions and classes that are needed by
the @code{arrayCGH} packages.")
(license license:gpl2+)))
+
+(define-public r-cghcall
+ (package
+ (name "r-cghcall")
+ (version "2.40.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "CGHcall" version))
+ (sha256
+ (base32 "11pi6awz3858yb4s0z3qf3kcmsdgp6d4aj41g4lfix1sv5amllch"))))
+ (properties `((upstream-name . "CGHcall")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-cghbase" ,r-cghbase)
+ ("r-impute" ,r-impute)
+ ("r-dnacopy" ,r-dnacopy)
+ ("r-snowfall" ,r-snowfall)))
+ (home-page "http://bioconductor.org/packages/CGHcall")
+ (synopsis "Base functions and classes for arrayCGH data analysis")
+ (description "This package contains functions and classes that are needed by
+@code{arrayCGH} packages.")
+ (license license:gpl2+)))