aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRouby Pierre-Antoine <pierre-antoine.rouby@inria.fr>2018-04-25 13:48:50 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-26 16:10:30 +0200
commit25637b770ed154303f540655421b00c283358f11 (patch)
tree48a2ac7a97236f07b8aa42c73a21d5fa871a4e1f
parent28cae3389146ee575e29c6dfd77987883503568e (diff)
downloadguix-25637b770ed154303f540655421b00c283358f11.tar
guix-25637b770ed154303f540655421b00c283358f11.tar.gz
gnu: Add psm2.
* gnu/packages/linux.scm (psm2): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c7c057b349..8fc9c56d69 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 nee <nee-git@hidamari.blue>
;;; Copyright © 2017 Dave Love <fx@gnu.org>
+;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4631,3 +4632,51 @@ the @code{coretemp} module and sets the fan speed using the @code{applesmc}
module. It can be executed as a daemon or in the foreground with root
privileges.")
(license license:gpl3+)))
+
+(define-public psm2
+ (package
+ (name "psm2")
+ (version "10.3-46")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/intel/opa-psm2.git")
+ (commit (string-append "PSM2_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wadphv4rl5p38x6a3dgpbijlzqdvcn02cfafnp72nh9faz0zvlx"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags
+ `(,(string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
+ #:tests? #f
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'patch-Makefiles
+ (lambda _
+ (substitute* "Makefile"
+ (("/lib64") "/lib")
+ (("/usr") ""))
+ (substitute* "compat/Makefile"
+ (("/lib64") "/lib")
+ (("/usr") ""))
+ #t))
+ (replace 'install
+ (lambda _
+ (setenv "DESTDIR" %output)
+ (invoke "make" "install")
+ #t)))))
+ (inputs
+ `(("rdma-core" ,rdma-core)
+ ("numactl" ,numactl)))
+ (synopsis "Intel Performance Scaled Messaging 2 (PSM2) library")
+ (description
+ "This package is low-level user-level Intel's communications interface.
+The PSM2 API is a high-performance vendor-specific protocol that provides a
+low-level communications interface for the Intel Omni-Path family of
+high-speed networking devices.")
+ (home-page "https://github.com/intel/opa-psm2")
+ ;; Only the x86_64 architecure is supported.
+ (supported-systems '("x86_64-linux"))
+ (license (list license:bsd-3 license:gpl2)))) ; dual