aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-04-24 16:55:25 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-25 23:11:53 +0200
commit06c4778ae290c9f8de5f8ef1683cec14de8f2ebc (patch)
tree564800a446ab4be7923b63b450551a5521e6a0be
parent0afeda65218ed0c82ab18762111c52a9fedd2582 (diff)
downloadguix-06c4778ae290c9f8de5f8ef1683cec14de8f2ebc.tar
guix-06c4778ae290c9f8de5f8ef1683cec14de8f2ebc.tar.gz
build: Add silent rules for Texinfo xref translation.
* Makefile.am (AM_V_POXREF, AM_V_POXREF_, AM_V_POXREF_0): New variables. * doc/local.mk ($(srcdir)/%D%/guix.%.texi) ($(srcdir)/%D%/contributing.%.texi): Use $(AM_V_POXREF).
-rw-r--r--Makefile.am4
-rw-r--r--doc/local.mk6
2 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 86528e8fdd..9f134c9708 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -800,3 +800,7 @@ AM_V_HELP2MAN_0 = @echo " HELP2MAN" $@;
AM_V_PO4A = $(AM_V_PO4A_$(V))
AM_V_PO4A_ = $(AM_V_PO4A_$(AM_DEFAULT_VERBOSITY))
AM_V_PO4A_0 = @echo " PO4A" $@;
+
+AM_V_POXREF = $(AM_V_POXREF_$(V))
+AM_V_POXREF_ = $(AM_V_POXREF_$(AM_DEFAULT_VERBOSITY))
+AM_V_POXREF_0 = @echo " POXREF" $@;
diff --git a/doc/local.mk b/doc/local.mk
index 64d18e121a..1bfc03aba8 100644
--- a/doc/local.mk
+++ b/doc/local.mk
@@ -1,6 +1,6 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
-# Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013 Andreas Enge <andreas@enge.fr>
# Copyright © 2016 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
# Copyright © 2016, 2018 Mathieu Lirzin <mthl@gnu.org>
@@ -93,12 +93,12 @@ endef
$(srcdir)/%D%/guix.%.texi: po/doc/guix.%.po $(srcdir)/%D%/contributing.%.texi
-$(AM_V_PO4A)$(PO4A_TRANSLATE) $(PO4A_PARAMS) -m "%D%/guix.texi" -p "$<" -l "$@.tmp"
-sed -i "s|guix\.info|$$(basename "$@" | sed 's|texi$$|info|')|" "$@.tmp"
- -$(xref_command)
+ -$(AM_V_POXREF)$(xref_command)
-mv "$@.tmp" "$@"
$(srcdir)/%D%/contributing.%.texi: po/doc/guix.%.po po/doc/contributing.%.po
-$(AM_V_PO4A)$(PO4A_TRANSLATE) $(PO4A_PARAMS) -m "%D%/contributing.texi" -p "$(word 2,$^)" -l "$@.tmp"
- -$(xref_command)
+ -$(AM_V_POXREF)$(xref_command)
-mv "$@.tmp" "$@"
%D%/os-config-%.texi: gnu/system/examples/%.tmpl