aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-04-23 08:07:10 +0200
committerRutger Helling <rhelling@mykolab.com>2018-04-23 15:44:39 +0200
commit06079c196c426cd84242c4e55b7227bcc5ecf290 (patch)
tree81752cdf37bdb92e142d9dac83d9c002d7398abe
parent5e5d6613a3837586ccab51cd988b44c7df99253b (diff)
downloadguix-06079c196c426cd84242c4e55b7227bcc5ecf290.tar
guix-06079c196c426cd84242c4e55b7227bcc5ecf290.tar.gz
gnu: ffmpeg: Update to 4.0.
* gnu/packages/video.scm (ffmpeg): Update to 4.0. * gnu/packages/video.scm (ffmpeg@3.4): New variable. * gnu/packages/video.scm (ffmpeg-git): Remove variable. * gnu/packages/video.scm (mpv)[inputs]: Build with ffmpeg instead of ffmpeg-git. * gnu/packages/gstreamer.scm (gst-libav)[inputs]: Build with ffmpeg@3.4 instead of ffmpeg. * gnu/packages/messaging.scm (qtox)[inputs]: Build with ffmpeg@3.4 instead of ffmpeg. * gnu/packages/emulators.scm (dolphin-emu)[inputs]: Build with ffmpeg@3.4 instead of ffmpeg. * gnu/packages/gnunet.scm (libextractor)[inputs]: Build with ffmpeg@3.4 instead of ffmpeg.
-rw-r--r--gnu/packages/emulators.scm2
-rw-r--r--gnu/packages/gnunet.scm2
-rw-r--r--gnu/packages/gstreamer.scm2
-rw-r--r--gnu/packages/messaging.scm2
-rw-r--r--gnu/packages/video.scm37
5 files changed, 19 insertions, 26 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 79947059bd..75b191c067 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -186,7 +186,7 @@
("bluez" ,bluez)
("curl" ,curl)
("eudev" ,eudev)
- ("ffmpeg" ,ffmpeg)
+ ("ffmpeg" ,ffmpeg-3.4)
("font-wqy-microhei" ,font-wqy-microhei)
("freetype" ,freetype)
("glew" ,glew)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index b6062625c0..880fb9f09e 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -88,7 +88,7 @@
`(("exiv2" ,exiv2)
("bzip2" ,bzip2)
("flac" ,flac)
- ("ffmpeg" ,ffmpeg)
+ ("ffmpeg" ,ffmpeg-3.4)
("file" ,file) ;libmagic, for the MIME plug-in
("glib" ,glib)
("gstreamer" ,gstreamer)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 6747c388d5..4eef9e741d 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -403,7 +403,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
("python" ,python)))
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
- ("ffmpeg" ,ffmpeg)
+ ("ffmpeg" ,ffmpeg-3.4)
("orc" ,orc)
("zlib" ,zlib)))
(home-page "https://gstreamer.freedesktop.org/")
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2b3284ba6f..237a315239 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -913,7 +913,7 @@ instant messenger with audio and video chat capabilities.")
,(list (string-append (assoc-ref inputs "qtsvg")
"/lib/qt5/plugins/"))))))))))
(inputs
- `(("ffmpeg" ,ffmpeg)
+ `(("ffmpeg" ,ffmpeg-3.4)
("filteraudio" ,filteraudio)
("glib" ,glib)
("gtk+" ,gtk+-2)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e959accf6a..1966d44dfd 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -597,14 +597,14 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
(define-public ffmpeg
(package
(name "ffmpeg")
- (version "3.4.2")
+ (version "4.0")
(source (origin
(method url-fetch)
(uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
version ".tar.xz"))
(sha256
(base32
- "0h6prjn1ijkzzhkyj8mazp0wpx7m0n9ycadjxagf9czqirbyk4ib"))))
+ "0gx4ngnhi5glmxh38603qy5n6vq8bl1cr4sqd1xff95i82pmv57d"))))
(build-system gnu-build-system)
(inputs
`(("fontconfig" ,fontconfig)
@@ -770,6 +770,18 @@ convert and stream audio and video. It includes the libavcodec
audio/video codec library.")
(license license:gpl2+)))
+(define-public ffmpeg-3.4
+ (package
+ (inherit ffmpeg)
+ (version "3.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0h6prjn1ijkzzhkyj8mazp0wpx7m0n9ycadjxagf9czqirbyk4ib"))))))
+
(define-public ffmpeg-2.8
(package
(inherit ffmpeg)
@@ -790,25 +802,6 @@ audio/video codec library.")
flag))
,flags))))))
-;; Annoyingly enough, the latest mpv release does not build with the stable
-;; release of ffmpeg. Use a git commit until the situation is fixed.
-(define-public ffmpeg-git
- (let ((commit "3f887440677328c9cfed97ad81d14051ffa32aae")
- (revision "1"))
- (package
- (inherit ffmpeg)
- (name "ffmpeg-git")
- (version (string-append "3.4-" revision "." (string-take commit 9)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/FFmpeg/FFmpeg.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1b7n3g4m2rbvrwsgbfl8wl91z42g1ld42clwxs8qpl9ny5rwz6sq")))))))
-
(define-public vlc
(package
(name "vlc")
@@ -1032,7 +1025,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(inputs
`(("alsa-lib" ,alsa-lib)
("enca" ,enca)
- ("ffmpeg" ,ffmpeg-git)
+ ("ffmpeg" ,ffmpeg)
("jack" ,jack-1)
("ladspa" ,ladspa)
("lcms" ,lcms)