aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-31 16:29:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-31 16:29:53 +0100
commit740a335558a440245a2374fae9ffaa3427aa546c (patch)
treed95ba3542d76a400f3cb2d99c36c74f3a31c787d
parent395a95bb7552ccb547cd4f3de4123b124632cf6e (diff)
downloadguix-740a335558a440245a2374fae9ffaa3427aa546c.tar
guix-740a335558a440245a2374fae9ffaa3427aa546c.tar.gz
gnu: Remove xboing.
* gnu/packages/games.scm (xboing): Remove variable.
-rw-r--r--gnu/packages/games.scm51
1 files changed, 0 insertions, 51 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8d388c0fdc..e908a570ca 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1535,57 +1535,6 @@ fully interactive graphical interface and it can load and save games in the
Portable Game Notation.")
(license license:gpl3+)))
-(define-public xboing
- (package
- (name "xboing")
- (version "2.4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://www.techrescue.org/xboing/xboing"
- version ".tar.gz"))
- (sha256
- (base32 "16m2si8wmshxpifk861vhpqviqxgcg8bxj6wfw8hpnm4r2w9q0b7"))
- (patches (search-patches "xboing-CVE-2004-0149.patch"))))
- (arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
-
- (substitute* "Imakefile"
- (("XPMINCLUDE[\t ]*= -I/usr/X11/include/X11")
- (string-append "XPMINCLUDE = -I"
- (assoc-ref %build-inputs "libxpm")
- "/include/X11")))
-
- (substitute* "Imakefile"
- (("XBOING_DIR = \\.") "XBOING_DIR=$(PROJECTROOT)"))
-
- ;; FIXME: HIGH_SCORE_FILE should be set to somewhere writeable
-
- (invoke "xmkmf" "-a"
- (string-append "-DProjectRoot="
- (assoc-ref outputs "out")))))
- (add-before 'install 'install-man-pages
- (lambda _ (invoke "make" "install.man"))))))
- (inputs `(("libx11" ,libx11)
- ("libxext" ,libxext)
- ("libxpm" ,libxpm)))
- (native-inputs `(("imake" ,imake)
- ("inetutils" ,inetutils)
- ("makedepend" ,makedepend)))
- (build-system gnu-build-system)
- (home-page "http://www.techrescue.org/xboing")
- (synopsis "Ball and paddle game")
- (description "XBoing is a blockout type game where you have a paddle which
-you control to bounce a ball around the game zone destroying blocks with a
-proton ball. Each block carries a different point value. The more blocks you
-destroy, the better your score. The person with the highest score wins.")
- (license (license:x11-style "file://COPYING"
- "Very similar to the X11 licence."))))
-
(define-public gtypist
(package
(name "gtypist")