aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-02-19 22:16:16 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-02-23 16:54:45 +0100
commit33a212bf88904295ddc20fcb05a4c237205812f8 (patch)
tree5b4fff1b29add138a0f23134ec30b5dfb0f8b495
parent892d39515251ae4de70a71e4d761c3decb428892 (diff)
downloadguix-33a212bf88904295ddc20fcb05a4c237205812f8.tar
guix-33a212bf88904295ddc20fcb05a4c237205812f8.tar.gz
gnu: Add pwsafe-cli.
* gnu/packages/password-utils.scm (pwsafe-cli): New variable. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/password-utils.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index ef4bf535a4..655834f754 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,6 +59,7 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages aidc)
#:use-module (gnu packages authentication)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -255,6 +257,49 @@ There are other programs that support the file format on different
platforms.")
(license license:artistic2.0)))
+(define-public pwsafe-cli
+ (let ((commit "c49a0541b66647ad04d19ddb351d264054c67759")
+ (revision "0"))
+ (package
+ (name "pwsafe-cli")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nsd20463/pwsafe")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ak09r1l7k57m6pdx468hhzvz0szmaq42vyr575fvsjc8rbrp8qq"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; FIXME: skip failing test suite (requires write access
+ ; to /tmp), patching path does not help somehow.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "aclocal")
+ (invoke "autoheader")
+ (invoke "automake" "--add-missing")
+ (invoke "autoconf")
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs
+ `(("openssl" ,openssl)
+ ("libx11" ,libx11)
+ ("libxt" ,libxt)
+ ("libxmu" ,libxmu)))
+ (home-page "https://github.com/nsd20463/pwsafe")
+ (synopsis "CLI password manager")
+ (description "Command line tool compatible with Counterpane's
+Passwordsafe.")
+ (license license:gpl2))))
+
(define-public shroud
(package
(name "shroud")