aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-29 22:58:42 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-05 20:33:37 +0100
commit0a1bf319dea711f7a28dc92af908eef6d8a51863 (patch)
treecb447735fc14e623deea6c3c7e10d5e0bf49d8d6
parent8344007781d013f4a714e924be8072dc513c69bd (diff)
downloadguix-0a1bf319dea711f7a28dc92af908eef6d8a51863.tar
guix-0a1bf319dea711f7a28dc92af908eef6d8a51863.tar.gz
gnu: emacs-orderless: Update to 0.8.
* gnu/packages/emacs-xyz.scm (emacs-orderless): Update to 0.8.
-rw-r--r--gnu/packages/emacs-xyz.scm57
1 files changed, 29 insertions, 28 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a06469662e..cd3091013d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9959,38 +9959,39 @@ interface.")
(license license:expat)))
(define-public emacs-orderless
- (package
- (name "emacs-orderless")
- (version "0.7")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/oantolin/orderless")
- (commit version)))
- (sha256
- (base32 "0m9nyz80j0qnn14drbgk8vn5yr7sv0z6yiz8w95ahcw2qwlgyjs7"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'makeinfo
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "makeinfo" "orderless.texi")
- (install-file "orderless.info"
- (string-append (assoc-ref outputs "out")
- "/share/info")))))))
- (native-inputs
- (list texinfo))
- (home-page "https://github.com/oantolin/orderless")
- (synopsis "Emacs completion style that matches multiple regexps in any order")
- (description "This package provides an orderless completion style that
+ (let ((commit "004cee6b8e01f8eb0cb1c683d0a637b14890600f"))
+ (package
+ (name "emacs-orderless")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oantolin/orderless")
+ (commit commit)))
+ (sha256
+ (base32 "115bwqi2yc44bgvcl7lha8p2s6jgh5hksn4wa9s0kpfxhi14jwmy"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'makeinfo
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "makeinfo" "orderless.texi")
+ (install-file "orderless.info"
+ (string-append (assoc-ref outputs "out")
+ "/share/info")))))))
+ (native-inputs
+ (list texinfo))
+ (home-page "https://github.com/oantolin/orderless")
+ (synopsis "Emacs completion style that matches multiple regexps in any order")
+ (description "This package provides an orderless completion style that
divides the pattern into space-separated components, and matches candidates
that match all of the components in any order. Each component can match in
any one of several ways: literally, as a regexp, as an initialism, in the flex
style, or as multiple word prefixes.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-consult
(package