aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-26 11:34:22 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-26 12:29:48 +0200
commitfb4fcfab9d961726436d165252042a2e711bb6da (patch)
tree5f41aee7e54098b2fe723aa90f57d4ba0e3fb1ba
parentfb075e2fda6d95e204d948357a28c36cfd7a446a (diff)
downloadguix-fb4fcfab9d961726436d165252042a2e711bb6da.tar
guix-fb4fcfab9d961726436d165252042a2e711bb6da.tar.gz
gnu: python-gpg: Update to 1.10.0.
* gnu/packages/gnupg.scm (python-gpg): Update to 1.10.0. [arguments]: Add custom phase to set 'gcc' call.
-rw-r--r--gnu/packages/gnupg.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 53fdc8200c..951fc05fa2 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -471,16 +471,23 @@ interface (FFI) of Guile.")
(define-public python-gpg
(package
(name "python-gpg")
- (version "1.8.0")
+ (version "1.10.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "gpg" version))
(sha256
(base32
- "1x74i6q713c0bckls7rdm8kgsmllf9qvy9x62jghszlhgjkyh9nd"))))
+ "1ji3ynhp36m1ccx7bmaq75dhij9frpn19v9mpi4aajn8csl194il"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f)) ; No test suite.
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-environment
+ (lambda _
+ (substitute* "setup.py"
+ (("cc") (which "gcc")))
+ #t)))
+ #:tests? #f)) ; No test suite.
(inputs
`(("gpgme" ,gpgme)))
(native-inputs