aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-28 19:21:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-10-30 21:33:37 +0100
commitefefd3ec42be0125f71066995b94ab8c6a26cde4 (patch)
tree5cf329793add41ff2d83df241eb9a4e3e47a0818
parent153e5b2ddc2d4ffa8cdfad4f5a3154be0b115551 (diff)
downloadguix-efefd3ec42be0125f71066995b94ab8c6a26cde4.tar
guix-efefd3ec42be0125f71066995b94ab8c6a26cde4.tar.gz
gnu: Add r-usethis.
* gnu/packages/cran.scm (r-usethis): New variable.
-rw-r--r--gnu/packages/cran.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 74e8367a29..00aa963473 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6779,3 +6779,38 @@ operations, built on top of the libuv C library.")
when building command line applications. They fall back to alternatives on
terminals that do not support Unicode.")
(license license:expat)))
+
+(define-public r-usethis
+ (package
+ (name "r-usethis")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "usethis" version))
+ (sha256
+ (base32
+ "1gadckx3sxz9gxvpkprj9x7zcgg2nz5m4q0vi76ya9li1v03rwwn"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-clipr" ,r-clipr)
+ ("r-clisymbols" ,r-clisymbols)
+ ("r-crayon" ,r-crayon)
+ ("r-curl" ,r-curl)
+ ("r-desc" ,r-desc)
+ ("r-fs" ,r-fs)
+ ("r-gh" ,r-gh)
+ ("r-git2r" ,r-git2r)
+ ("r-glue" ,r-glue)
+ ("r-rlang" ,r-rlang)
+ ("r-rprojroot" ,r-rprojroot)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-whisker" ,r-whisker)))
+ (home-page "https://github.com/r-lib/usethis")
+ (synopsis "Automate R package and project setup")
+ (description
+ "This package helps you to automate R package and project setup tasks
+that are otherwise performed manually. This includes setting up unit testing,
+test coverage, continuous integration, Git, GitHub integration, licenses,
+Rcpp, RStudio projects, and more.")
+ (license license:gpl3)))