aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-30 14:09:03 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-30 14:09:18 +0200
commitea593fe2984ca665c864160d2bd5e40362a4eb09 (patch)
tree02b95a6c1895e2374728519010ed69997e7a639e
parent48c8d067d4ded776939cda6f9c63c25b38ba77fc (diff)
downloadguix-ea593fe2984ca665c864160d2bd5e40362a4eb09.tar
guix-ea593fe2984ca665c864160d2bd5e40362a4eb09.tar.gz
gnu: vlc: Update to 3.0.5.
* gnu/packages/video.scm (vlc): Update to 3.0.5. [source]: Remove patch. (%vlc-libx264-compat.patch): Remove variable.
-rw-r--r--gnu/packages/video.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 322b88ece0..cc20ca08db 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -916,31 +916,19 @@ thumbnailer uses ffmpeg to decode frames from the video files, so supported
videoformats depend on the configuration flags of ffmpeg.")
(license license:gpl2+)))
-;; Fix build with newer x264.
-(define %vlc-libx264-compat.patch
- (origin
- (method url-fetch)
- (uri (string-append "https://git.videolan.org/?p=vlc.git;a=patch;h="
- "a8953ba707cca1f2de372ca24513296bcfcdaaa8"))
- (file-name "vlc-libx264-compat.patch")
- (sha256
- (base32
- "04igckbdp3sbp8vh0ihmhcf3yjyyk9r3cd5dm9mn9j6vipi1dg3g"))))
-
(define-public vlc
(package
(name "vlc")
- (version "3.0.4")
+ (version "3.0.5")
(source (origin
(method url-fetch)
(uri (string-append
"https://download.videolan.org/pub/videolan/vlc/"
(car (string-split version #\-))
"/vlc-" version ".tar.xz"))
- (patches (list %vlc-libx264-compat.patch))
(sha256
(base32
- "17jsq0zqpqyxw4ckvjba0hf6zk8ywc4wf8sy3z03hh3ij0vxpwq1"))))
+ "1nvj00khy08sing0mdnw6virmiq579mrk5rvpx9710nlxggqgh7m"))))
(build-system gnu-build-system)
(native-inputs
`(("flex" ,flex)