aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-10-12 17:51:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-13 11:14:00 +0200
commitdc8ddbfb076e769d9a63d458e195c4705188bc0c (patch)
tree4c9c00a4da14fc02305f50682250d0d09bdd9474
parentf3eeca5621ac7c3644895e253395878dfdbdd87e (diff)
downloadguix-dc8ddbfb076e769d9a63d458e195c4705188bc0c.tar
guix-dc8ddbfb076e769d9a63d458e195c4705188bc0c.tar.gz
gnu: Add paml.
* gnu/packages/bioinformatics.scm (paml): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9a47b076c9..112d0e577c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10085,3 +10085,51 @@ straight away. Its main features are:
and CHH context
@end itemize\n")
(license license:gpl3+)))
+
+(define-public paml
+ (package
+ (name "paml")
+ (version "4.9e")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://abacus.gene.ucl.ac.uk/software/"
+ "paml" version ".tgz"))
+ (sha256
+ (base32
+ "13zf6h9fiqghwhch2h06x1zdr6s42plsnqahflp5g7myr3han3s6"))
+ (modules '((guix build utils)))
+ ;; Remove Windows binaries
+ (snippet
+ '(begin
+ (for-each delete-file (find-files "." "\\.exe$"))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; there are no tests
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* "src/BFdriver.c"
+ (("/bin/bash") (which "bash")))
+ (chdir "src")
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((tools '("baseml" "basemlg" "codeml"
+ "pamp" "evolver" "yn00" "chi2"))
+ (bin (string-append (assoc-ref outputs "out") "/bin"))
+ (docdir (string-append (assoc-ref outputs "out")
+ "/share/doc/paml")))
+ (mkdir-p bin)
+ (for-each (lambda (file) (install-file file bin)) tools)
+ (copy-recursively "../doc" docdir)
+ #t))))))
+ (home-page "http://abacus.gene.ucl.ac.uk/software/paml.html")
+ (synopsis "Phylogentic analysis by maximum likelihood")
+ (description "PAML (for Phylogentic Analysis by Maximum Likelihood)
+contains a few programs for model fitting and phylogenetic tree reconstruction
+using nucleotide or amino-acid sequence data.")
+ ;; GPLv3 only
+ (license license:gpl3)))