aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-10-16 16:53:06 +0200
committerFederico Beffa <beffa@fbengineering.ch>2016-10-19 08:44:11 +0200
commitdb61a00971fbc4f197dd147419fa66212169e4b4 (patch)
tree563618ad38ad3b9043716e8d1127e91947180cea
parent4225c7116d934167dee3cfab2ff04d57c6a1e46a (diff)
downloadguix-db61a00971fbc4f197dd147419fa66212169e4b4.tar
guix-db61a00971fbc4f197dd147419fa66212169e4b4.tar.gz
gnu: Add ghc-easyplot.
* gnu/packages/haskell.scm (ghc-easyplot): New variable.
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1c16e18ad8..8d8330805e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7725,4 +7725,28 @@ functions for Haskell.")
interface for statistics based on hmatrix and GSL.")
(license license:bsd-3)))
+(define-public ghc-easyplot
+ (package
+ (name "ghc-easyplot")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/easyplot/easyplot-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "18kndgvdj2apjpfga6fp7m16y1gx8zrwp3c5vfj03sx4v6jvciqk"))))
+ (build-system haskell-build-system)
+ (propagated-inputs `(("gnuplot" ,gnuplot)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'fix-setup-suffix
+ (lambda _ (rename-file "Setup.lhs" "Setup.hs") #t)))))
+ (home-page "http://hub.darcs.net/scravy/easyplot")
+ (synopsis "Haskell plotting library based on gnuplot")
+ (description "This package provides a plotting library for
+Haskell, using gnuplot for rendering.")
+ (license license:expat)))
+
;;; haskell.scm ends here