aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-25 21:16:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-25 22:05:48 +0200
commitcfa3b7182d156753fcbdf419b152ce8285d1a0be (patch)
tree6fadd9a3a12e28f2819751376cbe6078d38fc94f
parent5895696e4c28938d9201e4527d3a007dd8b47e32 (diff)
downloadguix-cfa3b7182d156753fcbdf419b152ce8285d1a0be.tar
guix-cfa3b7182d156753fcbdf419b152ce8285d1a0be.tar.gz
gnu: translate-shell: Use 'git-fetch'.
* gnu/packages/dictionaries.scm (translate-shell)[source]: Use 'git-fetch'. [arguments]: Add custom phase to remove "translate" file.
-rw-r--r--gnu/packages/dictionaries.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 039ec45965..cb633c2f34 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -250,18 +250,24 @@ and a Python library.")
(version "0.9.6.8")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/soimort/" name "/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url"https://github.com/soimort/translate-shell.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "17yc2kwk8957wwxyih0jmsai720ai2yqyvmrqrglcncqg6zdbz9w"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "17fc5nlc594lvmihx39h4ddmi8ja3qqsyswzxadbaz7l3zm356b8"))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure phase
+ (add-after 'unpack 'remove-unnecessary-file
+ ;; This file gets generated during the build phase.
+ (lambda _
+ (delete-file "translate")
+ #t))
(add-after 'install 'emacs-install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))