aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:54:32 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:53 +0000
commitbda77ea6a346fccc6e9c7e842fdd345a93d94c25 (patch)
tree028e2de42226aac461626d26ceeb75e1c2d8a3cb
parentf66bd63e86f7788f1abe076d951d6d36f5ae6ff1 (diff)
downloadguix-bda77ea6a346fccc6e9c7e842fdd345a93d94c25.tar
guix-bda77ea6a346fccc6e9c7e842fdd345a93d94c25.tar.gz
gnu: Add coala.
-rw-r--r--gnu/packages/python.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3ecdc1b7e3..0c13e39f5f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15206,3 +15206,50 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(synopsis "Log formatting with colors!")
(description "Log formatting with colors!")
(license #f)))
+
+(define-public coala
+ (package
+ (name "coala")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "coala" version))
+ (sha256
+ (base32
+ "03mz2alvjf9aki5cpjl9167bd5kw0aqp8yml08lb5170gpsfyjyd"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-requires
+ (lambda _
+ (for-each (lambda (requirement)
+ (substitute* "requirements.txt"
+ (((string-append requirement "~="))
+ (string-append requirement ">="))))
+ '("testfixtures"
+ "libclang-py3"
+ "colorlog"))
+ #t)))))
+ (propagated-inputs
+ `(("python-appdirs" ,python-appdirs)
+ ("python-coala-utils" ,python-coala-utils)
+ ("python-colorlog" ,python-colorlog)
+ ("python-dependency-management"
+ ,python-dependency-management)
+ ("python-libclang-py3" ,python-libclang-py3)
+ ("python-packaging" ,python-packaging)
+ ("python-pygments" ,python-pygments)
+ ("python-pyprint" ,python-pyprint)
+ ("python-requests" ,python-requests)
+ ("python-setuptools" ,python-setuptools)
+ ("python-testfixtures" ,python-testfixtures)
+ ("python-unidiff" ,python-unidiff)))
+ (home-page "http://coala.io/")
+ (synopsis
+ "Linting and Fixing Code for All Languages")
+ (description
+ "Linting and Fixing Code for All Languages")
+ (license #f)))