aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-01 09:49:21 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-02 16:02:51 +0200
commitac85107c9fe0e6224444fad4275df7d2146d3abb (patch)
tree9b60604cfeaac8836f97af1ea108470d2740ea0d
parente1e09bcb43626cceb96e29dc0c7a626fd6d4aba2 (diff)
downloadguix-ac85107c9fe0e6224444fad4275df7d2146d3abb.tar
guix-ac85107c9fe0e6224444fad4275df7d2146d3abb.tar.gz
gnu: Add emacs-evil-multiedit.
* gnu/packages/emacs.scm (emacs-evil-multiedit): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f589f23e84..fe9ac7b2f6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10692,3 +10692,32 @@ describing the key binding changes.")
"Use keybindings for the mu4e mail reader in Emacs that make sense for
Evil users.")
(license license:gpl3+)))
+
+(define-public emacs-evil-multiedit
+ (let ((commit "ea3d9177b74ab0bc65e55df9cc0a0b42e4ef815d"))
+ (package
+ (name "emacs-evil-multiedit")
+ (version (git-version "1.3.9" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hlissner/evil-multiedit")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "17zm35r474z8ras4xy7124pcb972d385pbdv4jxyj5vq042vq07w"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-evil" ,emacs-evil)
+ ("emacs-iedit" ,emacs-iedit)))
+ (home-page
+ "https://github.com/hlissner/evil-multiedit")
+ (synopsis "Multiple cursors for Evil mode")
+ (description
+ "This plugin was an answer to the lack of proper multiple cursor support
+in Emacs+Evil. It allows you to select and edit matches interactively,
+integrating @code{iedit-mode} into Evil mode with an attempt at sensible
+defaults.")
+ (license license:gpl3+))))