aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-12-29 21:42:01 -0500
committerDanny Milosavljevic <dannym@scratchpost.org>2018-12-30 10:20:38 +0100
commit92deb5cc920fcc7617302986180f1abee5fd2b26 (patch)
tree02cf8d6627d460e013df519f9008d6143d979cd9
parenta1814acf8256d5bc8e8676154893175fe41273ce (diff)
downloadguix-92deb5cc920fcc7617302986180f1abee5fd2b26.tar
guix-92deb5cc920fcc7617302986180f1abee5fd2b26.tar.gz
gnu: gdm: Pass XDG_DATA_DIRS into session environment.
* gnu/packages/gnome.scm (gdm)[arguments]: Update the pre-configure phase so that GDM preserves the XDG_DATA_DIRS variable when setting up the session environment. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 415398eeee..da12a29879 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2018 Jovany Leandro G.C <bit4bit@riseup.net>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5399,6 +5400,11 @@ libxml2.")
;; are met (provided GNOME is installed of course).
"gdm_session_set_environment_variable (self, \"XDG_CONFIG_DIRS\",\n"
" \"/run/current-system/profile/etc/xdg\");\n"
+ ;; The session bus (which GDM will initialize from the this
+ ;; session environment) needs to know where to find the system
+ ;; service files.
+ "gdm_session_set_environment_variable (self, \"XDG_DATA_DIRS\",\n"
+ " \"/run/current-system/profile/share\");\n"
)))
;; Look for custom GDM conf in /run/current-system.
(substitute* '("common/gdm-settings-desktop-backend.c")